Invalid module format

Asked by Jordi Armengol on 2011-02-13

I am trying to use emgd driver for a eie uibx device. But the emgd module doesn't load properly:

$ sudo modprobe emgd
FATAL: Error inserting emgd (/lib/modules/2.6.35-25-generic/updates/dkms/emgd.ko): Invalid module format

Question information

Language:
English Edit question
Status:
Solved
For:
Intel® EMGD driver Edit question
Assignee:
No assignee Edit question
Solved by:
Jordi Armengol
Solved:
2011-03-03
Last query:
2011-03-03
Last reply:
2011-02-23
Ben Straton (fanum) said : #1

I believe that occurs when you are trying to load a module that was created with a different version of the kernel or compiler. I invite you to join the discussion here:

http://ubuntuforums.org/showthread.php?t=1229345&page=321

It is a long tread, but still very active. Please provide more information like (where you downloaded the drivers from, what distro you are using (whatever version of ubuntu or others) and if you have tried the PPA

Jordi Armengol (jordiar) said : #2

It tried to load the drivers as suggested in https://wiki.ubuntu.com/HardwareSupportComponentsVideoCardsPoulsbo/ with Karmic Lucid and Maverick with no luck.

And this error appeared when trying to run the drivers suggested at https://launchpad.net/~gma500/+archive/emgd on Maverick.

Ben Straton (fanum) said : #3

So to clarify, you did not install the PSB drivers, but the EMGD drivers instead using the scripts from here https://launchpad.net/~gma500/+archive/emgd ?

Jordi Armengol (jordiar) said : #4

Yes that's what I did.

Ben Straton (fanum) said : #5

Ok, to help you further I will probably need more people involved, hop on this forum thread

http://ubuntuforums.org/showthread.php?t=1229345&page=321

Post a description of every step you have tried, the error code, and add the content of this file:

/var/log/Xorg.0.log

onto this site:

http://paste.ubuntu.com/

and include that link (the one it will create for you, with that info in it)

Jordi Armengol (jordiar) said : #6

I loaded the /var/log/Xorg.0.log file to http://paste.ubuntu.com/567875/

What I did was to install Ubuntu 10.10 netbook version.
Then I updated everything using the gnome Update Manager
After rebooting I followed the instructions on https://launchpad.net/~gma500/+archive/emgd
I removed the file /etc/X11/xorg.conf because in previous attempts it prevented the system to load the graphic environment.
After another reboot I noticed the default slow graphic software was still in place and I tried to load manually the emgd kernel module:

$ sudo modprobe emgd
FATAL: Error inserting emgd (/lib/modules/2.6.35-25-generic/updates/dkms/emgd.ko): Invalid module format

The hardware I am using is: http://paste.ubuntu.com/567876/ (result of a lshw)

Jordi Armengol (jordiar) said : #7

After doing:

sudo apt-get purge emgd-dkms xorg-emgd emgdui
sudo apt-get autoremove

And reinstalling again using the scripts from https://launchpad.net/~gma500/+archive/emgd

It seems that now emgd is loaded properly. But the screen doesn't display anything. I found this post that reflects what is now happening to me:

http://embedded.communities.intel.com/thread/4918

Unfortunatelly I don't quite get the solution. Could anyone help with this?

Thank you.

Ben Straton (fanum) said : #8

Yes, the EMGD drivers require a custom xorg.conf file. They are often specific to your device. What is the make and model of your device?

Ben Straton (fanum) said : #10

And you have tried editing the xorg.conf with your native resolution and rebooting?

Jordi Armengol (jordiar) said : #11

Yes. I think the problem either is that referenced in http://embedded.communities.intel.com/thread/4918 about different versions living together, or that the default xorg.conf is for laptop screens and with my device I am using an external screen.

Jordi Armengol (jordiar) said : #12

Using the xorg.conf file uploaded at http://paste.ubuntu.com/575046/ the graphic environment works again. The only problem is that sometimes windows appear filled with lines of random colors. If the window is minimized and then opened again it is displayed properly.