Unable to install gtk-3-dev

Asked by Jovan on 2016-05-17

hello everyone,

I'm trying to install gtk-3-dev because I need to build Gecko. Unfortunately aptitude tells me that there are several broken dependencies.

The following packages have unmet dependencies:
 libpango1.0-dev : Depends: libpango-1.0-0 (= 1.36.3-1ubuntu1.1) but 1.36.8-0ubuntu1~14.04~ricotz1 is installed.
                   Depends: libpangocairo-1.0-0 (= 1.36.3-1ubuntu1.1) but 1.36.8-0ubuntu1~14.04~ricotz1 is installed.
                   Depends: libpangoft2-1.0-0 (= 1.36.3-1ubuntu1.1) but 1.36.8-0ubuntu1~14.04~ricotz1 is installed.
                   Depends: libpangoxft-1.0-0 (= 1.36.3-1ubuntu1.1) but 1.36.8-0ubuntu1~14.04~ricotz1 is installed.
                   Depends: gir1.2-pango-1.0 (= 1.36.3-1ubuntu1.1) but 1.36.8-0ubuntu1~14.04~ricotz1 is installed.
 libxkbcommon-dev : Depends: libxkbcommon0 (= 0.4.1-0ubuntu1) but 0.4.3-2~14.04~ricotz1 is installed.
 libwayland-dev : Depends: libwayland-client0 (= 1.4.0-1ubuntu1) but 1.6.0-0ubuntu1~14.04~ricotz0 is installed.
                  Depends: libwayland-server0 (= 1.4.0-1ubuntu1) but 1.6.0-0ubuntu1~14.04~ricotz0 is installed.
                  Depends: libwayland-cursor0 (= 1.4.0-1ubuntu1) but 1.6.0-0ubuntu1~14.04~ricotz0 is installed.
 libglib2.0-0 : Breaks: libglib2.0-0:i386 (!= 2.42.2-0ubuntu1~14.04~ricotz0) but 2.40.2-0ubuntu1 is to be installed.
 libglib2.0-0:i386 : Breaks: libglib2.0-0 (!= 2.40.2-0ubuntu1) but 2.42.2-0ubuntu1~14.04~ricotz0 is installed.
 libglib2.0-dev : Depends: libglib2.0-0 (= 2.40.2-0ubuntu1) but 2.42.2-0ubuntu1~14.04~ricotz0 is installed.
 libxi-dev : Depends: libxi6 (= 2:1.7.1.901-1ubuntu1.1) but 2:1.7.4-1~14.04~ricotz1 is installed.
 libcairo2-dev : Depends: libcairo2 (= 1.13.0~20140204-0ubuntu1.1) but 1.14.2-1ubuntu1~trusty1 is installed.
                 Depends: libcairo-gobject2 (= 1.13.0~20140204-0ubuntu1.1) but 1.14.2-1ubuntu1~trusty1 is installed.
 libglib2.0-bin : Conflicts: libglib2.0-bin:i386 but 2.40.2-0ubuntu1 is to be installed.
 libglib2.0-bin:i386 : Conflicts: libglib2.0-bin but 2.42.2-0ubuntu1~14.04~ricotz0 is installed.
 libatk1.0-dev : Depends: libatk1.0-0 (= 2.10.0-2ubuntu2) but 2.14.0-1ubuntu1~trusty1 is installed.
                 Depends: gir1.2-atk-1.0 (= 2.10.0-2ubuntu2) but 2.14.0-1ubuntu1~trusty1 is installed.
 libgtk-3-dev : Depends: libgtk-3-0 (= 3.10.8-0ubuntu1.6) but 3.14.15-0ubuntu1~14.04~ricotz1 is installed.
                Depends: gir1.2-gtk-3.0 (= 3.10.8-0ubuntu1.6) but 3.14.15-0ubuntu1~14.04~ricotz1 is installed.

Can someone help me with this? is there any way to fix this issue? I read that others also had this problem, but couldn't find any solution.

Question information

Language:
English Edit question
Status:
Solved
For:
elementary OS Edit question
Assignee:
No assignee Edit question
Solved by:
Rico Tzschichholz
Solved:
2016-05-18
Last query:
2016-05-18
Last reply:
2016-05-18
Manfred Hampl (m-hampl) said : #1

The broken dependency messages refer to a PPA (ricotz1). Have you disabled that PPA recently?

I suggest that you either re-enable that PPA (if it is no more enabled), or revert all packages that you have installed from that PPA to the standard version.

Best Rico Tzschichholz (ricotz) said : #2

Looks more like you disabled ppa:elementary-os/os-patches which is required and must not be removed.

Jovan (titannano) said : #3

adding elementary-os/os-patches trusty main did the trick.

Thank you for your help!

Jovan (titannano) said : #4

Thanks Rico Tzschichholz, that solved my question.