Stuck at lightdm

Asked by Yaseen Noorani on 2013-06-25

Been using luna beta 2 and everythings been working well until now. I can't login to the system, when I input the user password the screen goes black for a moment and lightdm pops up again. This happens with both the user accounts on the system. Tried to use slim and gdm to login but both attempt to start gnome-session (which is not installed) and I don't know how to change that. Any help would be appreciated

Question information

Language:
English Edit question
Status:
Answered
For:
elementary OS Edit question
Assignee:
No assignee Edit question
Last query:
2013-06-25
Last reply:
2013-06-27
Heath Paddock (heathbar) said : #1

I started experiencing this bug again too. I linked to the bug in question. None of the proposed solutions worked for me, but I'll be sure to update the bug if I find something that works.

RibShark (ribshark) said : #2

I remember experiencing this bug in the past. Removing the .Xauthority and the .ICEauthority files from my home folder seemed to fix it. Here are some step by step instructions if you are unsure.

1) Once the lightdm login screen appears, press ctrl+alt+f1 to go to tty1.
2) Log in with your username (not display name, so no capital letters) and password (no characters will appear, but it will work) and press enter after each one.
3) After you do that, type "rm .Xauthority .ICEauthority" (without quotes), and press enter.
4) Press ctrl+alt+f7 to return back to the lightdm, and log in. (should work)

Can you help with this problem?

Provide an answer of your own, or ask Yaseen Noorani for more information if necessary.

To post a message you must log in.