Solid state drives and eOS

Asked by Brian Bentsen

I'm having a rather weird issue - on two different SSDs in two different laptops neither of the latest unstable builds (oct 27 and nov 1) will boot after installation. If I put an old standard hard disk into the laptop, no problem, works perfectly. On the same SSDs I have installed both Ubuntu 12.10 and Mint Nadia without issue. I have also tried both architectures, no difference.

When it boots up all I get is boot text display of the various services starting and stopping, then it halts and never continues the boot process.

Is elementary somehow SSD hostile? Anyone else experience this?

Question information

English Edit question
elementary OS Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
sanjiwatsuki (sanjiwatsuki) said :

For what it is worth, I am currently running eOS on an SSD. I have not had issues like this. Sometimes, I do get booted to tty, but I think that is an NVIDIA driver thing.

Revision history for this message
Brian Bentsen (bimsebasse) said :

Thanks Daniel - it remains a mystery!

Revision history for this message
Denys Kyselov (tamias) said :

Please check which NVIDIA drivers in use on your laptotp. I have bad starts on 304.48 and 310.14 experimental betas.
Currently i'm use 304.43 stable and there is no crashes anyway.

Revision history for this message
Brian Bentsen (bimsebasse) said :

So I need to drop to a boot prompt and uninstall the Nvidia drivers?

Revision history for this message
Brian Bentsen (bimsebasse) said :

And how does a hard drive influence how your graphics driver works? I haven't had issues with Nvidia drivers in eOS or any distro.

Revision history for this message
Denys Kyselov (tamias) said :

I still think that your problem not in SSD drive. Maybe you install beta nvidia drivers as Daniel said.
I was switch from beta to current and there is no problems on my SSD.
Can you tell me which SSD(Brand - model) in use?

I recommend to check nvidia drivers.
At first you must go to console by pressing Ctrl+Alt+F1...F5 on boot screen and login at your user.
$ dpkg --get-selections | grep nvidia

if you will see something other than this:
nvidia-common install
nvidia-current-updates install
nvidia-settings-updates install

you need to uninstall your drivers(packages names you can get from previous output)
$ sudo apt-get remove bad-driver-package1 bad-driver-package2

and install current:
$ sudo apt-get install nvidia-current-updates nvidia-settings-updates nvidia-common

$ sudo apt-cache search nvidia - will show to you all available nvidia drivers packages.

Revision history for this message
Brian Bentsen (bimsebasse) said :

But I have already installed and used both of the last two unstable builds on my laptop, with the same graphics card and whatever Nvidia drivers the installer activates by default, it worked flawlessly. Until I replace the old hard disk with an SSD, then it doesn't work.

Anyway, I will try!

SSDs: Intel SSD 330 & Crucial V4

Revision history for this message
Denys Kyselov (tamias) said :

He-he.. I reinstall eOS yesterday(unstable ppa broke start screen same as your problem) and after reboot i seen that bets drivers was installed as default. Two unstable components gives very explosive mix. :)
I switched to a stable version of the driver and the problem has not occurred yet. As you can see i use SSD(OCZ Vertex 3 60Gb) too.

Can you help with this problem?

Provide an answer of your own, or ask Brian Bentsen for more information if necessary.

To post a message you must log in.