How do I launch Pantheon Files as root?

Asked by Ronnie C on 2012-10-22

Sorry, I'm kind of new to linux. I've been using Ubuntu for about a year and a few days ago i installed Luna over my Ubuntu partition. I tried gksudo files, gksudo pantheon files, and gksudo nautilus and I can't get it to work. Can someone please help me?

Question information

Language:
English Edit question
Status:
Solved
For:
elementary OS Edit question
Assignee:
No assignee Edit question
Solved by:
Cody Garver
Solved:
2012-10-24
Last query:
2012-10-24
Last reply:
2012-10-22
Best Cody Garver (codygarver) said : #1

You can right click the dock icon and choose "New Window As Administrator"

or from command line $ gksudo pantheon-files

Saurabh Gupta (bhaismachine) said : #2

I had the same question few days back but then I found the right click method. Before that I tried using the terminal as I usually do and it didn't work. I receive the following error each time :

(gksudo:20159): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",
Gtk-Message: Failed to load module "canberra-gtk-module"

I didn't file any bug report for it thinking that it might be due my setup.

Ronnie C (ronnie-monster) said : #3

Thanks so much(:

Ronnie C (ronnie-monster) said : #4

Thanks Cody Garver, that solved my question.

Felix (felix-akkermans) said : #5

I also found this out pretty quickly. But to make this easier, and for consistency I'd recommend:

* Making an alias for "pantheon-files" in the commandline called "files". This is more obvious, and consistent with the application name in the user space.
* Making it possible to also right-click on an icon in slingshot and being able to select "Run as administrator"