Switching to SSL mode on server behind router breaks EHCP

Asked by Jack Lindsay on 2012-09-19

Hi.

I have an EHCP server running on AWS, and as the server is assigned a private IP behind Amazon's firewall, I encounter a big problem when I switch from non-SSL vhosts to SSL.

It appears that EHCP fails completely if it is configured with the external IP of the server, since it cannot bind to that. I fixed that problem by giving the server the internal IP, and that works now.

However, it appears the settings in apachehcp.conf are being incorrectly generated for the webmail settings on each domain.

Instead of the path /var/www/new/ehcp, the path is configured as /var/www/vhosts/ehcp, which no longer exists in the version I am using (0.30.4).

Thanks.

Jack

Question information

Language:
English Edit question
Status:
Answered
For:
Easy Hosting Control Panel for Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2012-09-19
Last reply:
2012-09-19
ehcpdeveloper (ehcpdeveloper) said : #1

can you send contents of files (in ehcp dir):
apachetemplate
apachetemplate_ipbased

etc/apache2/apachetemplate
etc/apache2/apachetemplate_ipbased

etc/apache2_ssl/apachetemplate
etc/apache2_ssl/apachetemplate_ipbased

Jason Brooks (jasonbbrooks) said : #2

Hello,

I have seen this too: I clicked the "fix apache configuration with ssl" by accident. It was such a show stopper I removed that link entirely to prevent accidents.

Can you help with this problem?

Provide an answer of your own, or ask Jack Lindsay for more information if necessary.

To post a message you must log in.