viewing vhost domains on local IP

Asked by Matthew Smith on 2011-09-23

My verizon router assumes internal connections to itself and all iget is my router login page. Is there a way to view vhost pages on local IP's without locking myself out of the control panel?

Question information

Language:
English Edit question
Status:
Solved
For:
Easy Hosting Control Panel for Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
ehcpdeveloper
Solved:
2011-09-23
Last query:
2011-09-23
Last reply:
2011-09-23
ehcpdeveloper (ehcpdeveloper) said : #1

please clarify.
what is your server ip?
what is your client/desktop ip ?

Matthew Smith (tetrambs) said : #2

Server is 192.168.2.50
client is 192.168.2.100

Unfortunately we don't have a static ip address so we use dynamic dns and port forwarding. tetra.is-a-geek.com If you want to take a look at my father's resume.

ehcpdeveloper (ehcpdeveloper) said : #3

What you see when you just type http://192.168.2.50
in your browser,
you see the page of your router ?

Matthew Smith (tetrambs) said : #4

When i type in the servers direct IP address i get the default page for ehcp with a link to login to the control panel.
When visiting tetra.is-a-geek.com (the address that points back to me) from home I get stuck with my routers login page. I spent an hour talking with verizon's tech support about the issue but they just told me I was SOL and i should speak with Westell (the router's manufacturer).

I had to setup "is-a-geek.com" as a domain and add "tetra" as a subdomain. Just making tetra.is-a-geek.com appear correctly.

Matthew Smith (tetrambs) said : #6

Thank you so much. Changing my host file did the trick. I shall no longer be crippled by verizon's router.

Matthew Smith (tetrambs) said : #7

Thanks ehcpdeveloper, that solved my question.

Wylie (falcon1) said : #8

I am having a similar issue. I have ehcp installed on a Debian Squeeze server setup as a firewall/gateway. I tried changing the hosts file on my personal machine as in #976 - I just get the EHCP default login page. What I really hope to get is a 'fake domain used to work on a site-in-development before moving the files to the real domain folders and be able to access it from my personal client something like ... 192.168.0.1/test-domain where test-domain exists only in the vhosts/user/...
Hoping someone can help.