session_start(): open_basedir restriction in effect. File(/tmp)

Asked by tpl99@yandex.ru on 2011-08-02

I've set the ehcp panel on my server successfully,
set the panel to respond to port 2082 on the default domain rather then having additional subdomain
but visitting http://domain.com:2082 I get a

Warning: session_start(): open_basedir restriction in effect. File(/tmp) is not within the allowed path(s): (/var/www/new/ehcp) in /var/www/new/ehcp/index.php on line 32 Fatal error: session_start(): Failed to initialize storage module: files (path: ) in /var/www/new/ehcp/index.php on line 32

Any way to sort it out leaving tempdir's yet local per user ?

Question information

Language:
English Edit question
Status:
Answered
For:
Easy Hosting Control Panel for Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2011-08-02
Last reply:
2011-08-02
ehcpdeveloper (ehcpdeveloper) said : #1

this is not a solution, but a comment:
I am not sure if session_start() directive of php has some session path setting.
it seems that, it is trying to access /tmp, but open_basedir allowing
only /var/www/new/ehcp
so, you need either:
* change open_basedir to use /tmp also, (in fact, changing
open_basedir to include /tmp is not recomended)
or
* use session_start directive with path in /var/www/new/ehcp , if
possible. I dont know how to do this; maybe there is a way to set this
in php.

hope this helps in solution.

Can you help with this problem?

Provide an answer of your own, or ask tpl99@yandex.ru for more information if necessary.

To post a message you must log in.