Having problems with EHCP

Asked by chris neuman on 2011-06-07

Hello support i'm wondering if you can help me resolve issues i'm having with EHCP or my VPS?
I'm trying to determine if the issues are with EHCP or with my VPS and have contacted support from my provider several times, but they're saying they are not familiar with EHCP to be able to help me, so i'm hoping you can help me track the source of my problems.
I have a VPS from slicehost, i've used ehcp with slicehost in the past with no problems, but this time i cannot get it working properly.
First my slice...i signed up for the VPS, pointed my domain name to their nameservers, then had to set A records and NS records. So my domain name resolved. Then i tried to create add on domains within EHCP, but the domain names would not resolve. Not sure why?
Anyway, i've now tried adding a sub domain and the sub was created in filemanager but i was unable to get to it via the web. After waiting half hour or so i tried a reboot, only to find i cannot even get my main site now.
Is the problem with EHCP, with my slice, or have i set something up wrong?
I did the install via your auto install on the homepage and tried it on several different platforms until i found one which worked, Ubuntu 9.10
Can't understand why nothing seems to work properly as i've had no issues in the past with the same set-up.

Edit: Contacted slicehost support and they say there is nothing wrong with the hardware. Tried restarting apache from the command line and got this error message:

 apache2: Syntax error on line 237 of /etc/apache2/apache2.conf: Syntax error on line 29 of /var/www/new/ehcp/apachehcp_subdomains.conf: Could not open configuration file /etc/apache2/fastcgi_params;: No such file or directory

How do i fix this?

Question information

Language:
English Edit question
Status:
Answered
For:
Easy Hosting Control Panel for Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2011-06-08
Last reply:
2011-06-11
ehcpdeveloper (ehcpdeveloper) said : #1

it is mostly you downloaded wrong file from ehcp.net
possible solutions (one of these):

1- apply commands described in http://ehcp.net/?q=node/897

or
2- re-download ehcp from www.ehcp.net/ehcp_latest.tgz or
www.ehcp.net/download and reinstall it.

if you still have problem, let me know.

On Wed, Jun 8, 2011 at 3:25 AM, chris neuman
<email address hidden> wrote:
> Question #160639 on Easy Hosting Control Panel for Ubuntu changed:
> https://answers.launchpad.net/ehcp/+question/160639
>
> Description changed to:
> Hello support i'm wondering if you can help me resolve issues i'm having with EHCP or my VPS?
> I'm trying to determine if the issues are with EHCP or with my VPS and have contacted support from my provider several times, but they're saying they are not familiar with EHCP to be able to help me, so i'm hoping you can help me track the source of my problems.
> I have a VPS from slicehost, i've used ehcp with slicehost in the past with no problems, but this time i cannot get it working properly.
> First my slice...i signed up for the VPS, pointed my domain name to their nameservers, then had to set A records and NS records. So my domain name resolved. Then i tried to create add on domains within EHCP, but the domain names would not resolve.  Not sure why?
> Anyway, i've now tried adding a sub domain and the sub was created in filemanager but i was unable to get to it via the web. After waiting half hour or so i tried a reboot, only to find i cannot even get my main site now.
> Is the problem with EHCP, with my slice, or have i set something up wrong?
> I did the install via your auto install on the homepage and tried it on several different platforms until i found one which worked, Ubuntu 9.10
> Can't understand why nothing seems to work properly as i've had no issues in the past with the same set-up.
>
>
> Edit: Contacted slicehost support and they say there is nothing wrong with the hardware. Tried restarting apache from the command line and got this error message:
>
>  apache2: Syntax error on line 237 of /etc/apache2/apache2.conf: Syntax
> error on line 29 of /var/www/new/ehcp/apachehcp_subdomains.conf: Could
> not open configuration file /etc/apache2/fastcgi_params;: No such file
> or directory
>
> How do i fix this?
>
> --
> You received this question notification because you are an answer
> contact for Easy Hosting Control Panel for Ubuntu.
>

chris neuman (chrisspectre) said : #2

Thanks for your reply, i installed ehcp using the commands on your homepage:
wget www.ehcp.net/ehcp_latest.tgz
tar -zxvf ehcp_latest.tgz
cd ehcp
./install.sh

I had to install it several times testing different platforms and it always seemed faulty. I think you might like to check it.

chris neuman (chrisspectre) said : #3

Hi there, thanks very much, appreciate it. Have used ehcp with slicehost in the past and had no problems at all, so can't understand why it's not gone well this time.
Details are:
IP: 50.57.79.169
user: root
pass: yiphee.com0tMNcrI43

Thanks very much

--- On Wed, 8/6/11, chris neuman <email address hidden> wrote:

From: chris neuman <email address hidden>
Subject: Re: [Question #160639]: Having problems with EHCP
To: <email address hidden>
Date: Wednesday, 8 June, 2011, 11:50

Your question #160639 on Easy Hosting Control Panel for Ubuntu changed:
https://answers.launchpad.net/ehcp/+question/160639

    Status: Answered => Open

You are still having a problem:
Thanks for your reply, i installed ehcp using the commands on your homepage:
wget www.ehcp.net/ehcp_latest.tgz
tar -zxvf ehcp_latest.tgz
cd ehcp
./install.sh

I had to install it several times testing different platforms and it
always seemed faulty. I think you might like to check it.

--
You received this question notification because you asked the question.

ehcpdeveloper (ehcpdeveloper) said : #4

is there anybody that knows, howto delete some post here (the one with pass)

btw, I updated ehcp today, to ver 0.29.15.4, because of a little bug.
if you live problem with subdomains, do update it.

ehcpdeveloper (ehcpdeveloper) said : #5

Now, I can understand why you suffered from "your pass is written in there... "

As I understand, you just replied to email, which posts the password
in launchpad.
you should not reply to answers.launchpad.net, with private info in it.

so, appearently, yourself did post the pass right out there...
anyway, sory to see this..
I cannot delete it now, if I find some way, i will do.

Dear Mr.Chris

please change your root password, that will help subside the security problem,

coming to enabling a better way to share the problem, need to implement some seperate system (ticket system like Kayako Suite), which offers way to post root password along with every support request.

hopefully, with or without (password sharing feature), any ticketing system may do too.

thing is, tickets are only viewable to support staff or admin kind of along with requesting user.

all technical solutions or detailed answers ( for repeated questions) need to be added to knowledgebase, which will be helpful.

==> to Mr.Bahattin: please think in this perspective, we need to have some ticketing system in place to deal sensitive information better, so, support questions are posted in ticket system, while, reporting bugs etc in launchpad?

Note: recommending minimum version of Ubuntu for EHCP, is another good thing hopefully, likewise about virtualisation architectures etc...

just some thoughts, thank you

With Best Regards
Raghu Veer

ehcpdeveloper (ehcpdeveloper) said : #7

we already have ticket system, http://support.ehcp.net , I setup a
username in support.ehcp.net/scp for you, securitywonks,
we are using launchpad additionally.
I am also receiving questions/problems in ticket system.
I am receiving approx 2000 mails/messages a day, on different topics.

thanks for suggestions,
see you.

Can you help with this problem?

Provide an answer of your own, or ask chris neuman for more information if necessary.

To post a message you must log in.