Disabling encrypted swap and home folder

Asked by papukaija on 2010-01-16

Due to performance problems in my old computer, I decided to disable encrypted home folders. So how to do it?

Question information

Language:
English Edit question
Status:
Solved
For:
eCryptfs Edit question
Assignee:
No assignee Edit question
Solved by:
papukaija
Solved:
2010-01-31
Last query:
2010-01-31
Last reply:
papukaija (papukaija) said : #1

I found http://ubuntuforums.org/showthread.php?t=1135796 but it's for Jaunty. Should it work in Karmic?

papukaija (papukaija) said : #2

I disabled encrypted swap by:
- uninstalling cryptsetup and then after restarting removed /etc/cryptab
- formatting my swap to use linux-swap as filesystem using gparted
-edited /etc/fstab by
   - deleting the swap line and uncommenting the installer's swap line
   - updating the uuid value by taking it's new value from gparted
- updating the same uuid value to /etc/initramfs-tools/conf.d/resume
- restarting

To disable encrypted home folder (after doing the above):
1) backup your files from your home folder (DON'T IGNORE THIS STEP, you need to restore the backupped files later)
2) login using an admin account (create a new one if your account is the only one in your system) and
    a) delete ecryptfs-utils package using synaptic or apt
    b) restart
    c) delete completely your old home folder including your folder inside the hidden ecryptfs folder in /home
   d) create yourself a new account
3) restore your backupped files (I warned you if you didn't backup your files)

This tutorial is written for Karmic and is provided as-is. I take no responsibility for any data loss.

papukaija (papukaija) said : #3

Please convert this question to a new FAQ.