eCryptfs autoumounts directory

Asked by miguel.gil.martinez on 2009-07-10

Directories encrypted and not used for a long time are automatically umounted. How can I set this feature up?

Question information

Language:
English Edit question
Status:
Solved
For:
eCryptfs Edit question
Assignee:
No assignee Edit question
Solved by:
Charnjit SiNGH
Solved:
2009-07-13
Last query:
2009-07-13
Last reply:
2009-07-11

Sometimes, when I try to list my home directory it show two files. One of them "README.txt" says:
"THIS DIRECTORY HAS BEEN UNMOUNTED TO PROTECT YOUR DATA.
From the graphical desktop, click on: "Access Your Private Data"
or
From the command line, run:
 $ ecryptfs-mount-private
"
I would like to know how to disable this feature, because I need to get this directory always mounted.

I am Ubuntu 9.04 Server Edition user.

Best Charnjit SiNGH (webdevhud) said : #3

Hiya, this is a feature by design.

It's a security feature, to block access when you have not accessed the folder for a long time.

However, if you really want to configure your system to NOT automatically unmount ~/Private (or other encrypted directories), you can do this by:

$ rm ~/.ecryptfs/auto-umount

(Deleting the file auto-umount in /home/your_username/.ecryptfs/)

^_^

Thanks Charnjit SiNGH, that solved my question.