mount -t ecryptfs (wrong fs type) auth sig

Asked by AlexGenaud on 2012-04-29

I have a few encrypted directories from at least a year ago. I am trying to open them manually with the following:

   $ sudo mount -t ecryptfs priv pub -o
      ecryptfs_cipher=aes,ecryptfs_key_bytes=16,
      ecryptfs_passthrough=n,ecryptfs_enable_filename_crypto=y,
      no_sig_cache

I am told:

   mount: wrong fs type, bad option, bad superblock on /home/alex/Sensitive/co,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail or so

Dmesg says (in so many words):

   ecryptfs_parse_options: eCryptfs: unrecognized option ...
   [ecryptfs_passthrough=n] ... [ecryptfs_enable_filename_crypto=y] ... [no_sig_cache]

Removing some/all options as suggested doesn't get me further. Dmesg again:

   ecryptfs_parse_options: You must supply at least one valid auth tok signature
   as a mount parameter; see the eCryptfs README
   Error parsing options; rc = [-22]

The "INTERACTIVE MOUNTING" section of http://ecryptfs.sourceforge.net/README seems to agree with me:

   $ mount -t ecryptfs /root/crypt /mnt/crypt

Question information

Language:
English Edit question
Status:
Solved
For:
eCryptfs Edit question
Assignee:
No assignee Edit question
Solved by:
AlexGenaud
Solved:
2012-04-29
Last query:
2012-04-29
Last reply:
AlexGenaud (alexgenaud) said : #1

=======
Solution :)
=======

$ sudo apt-get install ecryptfs-utils