logs filling up with eCryptfs error messages

Asked by elementz on 2011-05-16

I am observing a constant stream of the following error message filling up my /var/log/messages:

`Either the lower file is not in a valid eCryptfs format, or the key could not be retrieved. Plaintext passthrough mode is not enabled; returning -EIO`

I have already tried to find a solution to this. I am not sure if this actually a bug or a configuration error.
I did find a bug report under https://bugs.launchpad.net/ubuntu/+source/ecryptfs-utils/+bug/372014 , which does not really point to a solution.

I already tried to `rm -R ~/.cache`, which did not resolve the problem.

Not sure if this could be related or a totally different problem:
I am also having trouble changing permissions on some files in `/home/myuser/` when issuing `sudo chown myuser:myuser ~myuser -R` resulting with an io-error on some files.
I have already checked the sanity of the unmounted, encrypted filesystem via `e2fsck -c` and the state of the disk itself with smartmontools, which both indicate that the disk and filesystem are ok.

-----------------------------------------------------------
My system info:
separate /home partition encrypted with eCryptfs and formatted with ext4

lsb_release -a
LSB Version: core-2.0-amd64:core-2.0-noarch:core-3.0-amd64:core-3.0-noarch:core-3.1-amd64:core-3.1-noarch:core-3.2-amd64:core-3.2-noarch:core-4.0-amd64:core-4.0-noarch
Distributor ID: Ubuntu
Description: Ubuntu 10.10
Release: 10.10
Codename: maverick
--------------------------------------------------------

uname -r
2.6.35-28-generic

Question information

I'm having this same issue under the same conditions, with the addition that my system completely locks up as soon as the error occurs, which it does frequently.

The bug you reference has been marked as a duplicate and, on the main bug (https://bugs.launchpad.net/ecryptfs/+bug/509180), they seem to have created a fix, but it's not clear whether this has been pushed out. I've requested clarification in the hopes that there's a solution sometime soon.

Can you help with this problem?

Provide an answer of your own, or ask elementz for more information if necessary.

To post a message you must log in.