Error mounting eCryptfs: [-2] No such file or directory

Asked by wolfv on 2010-06-05

I am trying to recover my Private data manually, but get this error:
 Error mounting eCryptfs: [-2] No such file or directory

The same problem is marked "solved" at https://answers.launchpad.net/ecryptfs/+question/46307 but no solution was posted.

I followed "Setup Your Encrypted Private Directory" instructions on
https://help.ubuntu.com/community/EncryptedPrivateDirectory
Then I followed "Recovering Your Data Manually" instructions from the same page. The output is listed below:

----------------
wolf@copper:~$ ls .Private
ECRYPTFS_FNEK_ENCRYPTED.FWYqADyIB2z.dERjOv9viZzugZ-aEQpw-LoNoiDtb.NKkYYdFGkZbkskzE--

wolf@copper:~$ sudo ecryptfs-add-passphrase --fnek
[sudo] password for wolf:
Passphrase:
Inserted auth tok with sig [19ed9549e2d29b0f] into the user session keyring
Inserted auth tok with sig [3630ff94344fc1a5] into the user session keyring
wolf@copper:~$ sudo mount -t ecryptfs /home/username/.Private /home/username/Private
[sudo] password for wolf:
Passphrase:
Select cipher:
 1) aes: blocksize = 16; min keysize = 16; max keysize = 32 (not loaded)
 2) blowfish: blocksize = 16; min keysize = 16; max keysize = 56 (not loaded)
 3) des3_ede: blocksize = 8; min keysize = 24; max keysize = 24 (not loaded)
 4) twofish: blocksize = 16; min keysize = 16; max keysize = 32 (not loaded)
 5) cast6: blocksize = 16; min keysize = 16; max keysize = 32 (not loaded)
 6) cast5: blocksize = 8; min keysize = 5; max keysize = 16 (not loaded)
Selection [aes]:
Select key bytes:
 1) 16
 2) 32
 3) 24
Selection [16]:
Enable plaintext passthrough (y/n) [n]: n
Enable filename encryption (y/n) [n]: y
Filename Encryption Key (FNEK) Signature [19ed9549e2d29b0f]: 3630ff94344fc1a5
Attempting to mount with the following options:
  ecryptfs_unlink_sigs
  ecryptfs_fnek_sig=3630ff94344fc1a5
  ecryptfs_key_bytes=16
  ecryptfs_cipher=aes
  ecryptfs_sig=19ed9549e2d29b0f
WARNING: Based on the contents of [/root/.ecryptfs/sig-cache.txt],
it looks like you have never mounted with this key
before. This could mean that you have typed your
passphrase wrong.

Would you like to proceed with the mount (yes/no)? : yes
Would you like to append sig [19ed9549e2d29b0f] to
[/root/.ecryptfs/sig-cache.txt]
in order to avoid this warning in the future (yes/no)? : no
Not adding sig to user sig cache file; continuing with mount.
Error mounting eCryptfs: [-2] No such file or directory
Check your system logs; visit <http://launchpad.net/ecryptfs>

wolf@copper:~$ ls Private
Access-Your-Private-Data.desktop README.txt

----------------
Which system log should I be checking and what am I looking for?
https://help.ubuntu.com/community/LinuxLogFiles

I am testing this with a known passphrase. After I get this working with a known passphrase I will try recovering files with a questionable passphrase.

Thank you.

Question information

Language:
English Edit question
Status:
Solved
For:
eCryptfs Edit question
Assignee:
No assignee Edit question
Solved by:
Serge Hallyn
Solved:
2010-06-06
Last query:
2010-06-06
Last reply:
2010-06-05
Best Serge Hallyn (serge-hallyn) said : #1

When you say

$ sudo mount -t ecryptfs /home/username/.Private /home/username/Private

do you mean you actually typed 'username', or was that taken from a
howto page? Please make sure to use /home/wolf not /home/username.

On Sat, Jun 5, 2010 at 3:17 PM, wolfv
<email address hidden> wrote:
> Question #113590 on eCryptfs changed:
> https://answers.launchpad.net/ecryptfs/+question/113590
>
> Description changed to:
> I am trying to recover my Private data manually, but get this error:
>  Error mounting eCryptfs: [-2] No such file or directory
>
> The same problem is marked "solved" at
> https://answers.launchpad.net/ecryptfs/+question/46307 but no solution
> was posted.
>
> I followed "Setup Your Encrypted Private Directory" instructions on
> https://help.ubuntu.com/community/EncryptedPrivateDirectory
> Then I followed "Recovering Your Data Manually" instructions from the same page.  The output is listed below:
>
> ----------------
> wolf@copper:~$ ls .Private
> ECRYPTFS_FNEK_ENCRYPTED.FWYqADyIB2z.dERjOv9viZzugZ-aEQpw-LoNoiDtb.NKkYYdFGkZbkskzE--
>
> wolf@copper:~$ sudo ecryptfs-add-passphrase --fnek
> [sudo] password for wolf:
> Passphrase:
> Inserted auth tok with sig [19ed9549e2d29b0f] into the user session keyring
> Inserted auth tok with sig [3630ff94344fc1a5] into the user session keyring
> wolf@copper:~$ sudo mount -t ecryptfs /home/username/.Private /home/username/Private
> [sudo] password for wolf:
> Passphrase:
> Select cipher:
>  1) aes: blocksize = 16; min keysize = 16; max keysize = 32 (not loaded)
>  2) blowfish: blocksize = 16; min keysize = 16; max keysize = 56 (not loaded)
>  3) des3_ede: blocksize = 8; min keysize = 24; max keysize = 24 (not loaded)
>  4) twofish: blocksize = 16; min keysize = 16; max keysize = 32 (not loaded)
>  5) cast6: blocksize = 16; min keysize = 16; max keysize = 32 (not loaded)
>  6) cast5: blocksize = 8; min keysize = 5; max keysize = 16 (not loaded)
> Selection [aes]:
> Select key bytes:
>  1) 16
>  2) 32
>  3) 24
> Selection [16]:
> Enable plaintext passthrough (y/n) [n]: n
> Enable filename encryption (y/n) [n]: y
> Filename Encryption Key (FNEK) Signature [19ed9549e2d29b0f]: 3630ff94344fc1a5
> Attempting to mount with the following options:
>  ecryptfs_unlink_sigs
>  ecryptfs_fnek_sig=3630ff94344fc1a5
>  ecryptfs_key_bytes=16
>  ecryptfs_cipher=aes
>  ecryptfs_sig=19ed9549e2d29b0f
> WARNING: Based on the contents of [/root/.ecryptfs/sig-cache.txt],
> it looks like you have never mounted with this key
> before. This could mean that you have typed your
> passphrase wrong.
>
> Would you like to proceed with the mount (yes/no)? : yes
> Would you like to append sig [19ed9549e2d29b0f] to
> [/root/.ecryptfs/sig-cache.txt]
> in order to avoid this warning in the future (yes/no)? : no
> Not adding sig to user sig cache file; continuing with mount.
> Error mounting eCryptfs: [-2] No such file or directory
> Check your system logs; visit <http://launchpad.net/ecryptfs>
>
> wolf@copper:~$ ls Private
> Access-Your-Private-Data.desktop  README.txt
>
> ----------------
> Which system log should I be checking and what am I looking for?
> https://help.ubuntu.com/community/LinuxLogFiles
>
> I am testing this with a known passphrase.  After I get this working
> with a known passphrase I will try recovering files with a questionable
> passphrase.
>
> Thank you.
>
> --
> You received this question notification because you are a member of
> eCryptfs Developers, which is an answer contact for eCryptfs.
>

wolfv (wolf-volpi) said : #2

Thanks Serge Hallyn, that solved my question.

wolfv (wolf-volpi) said : #3

Thanks again Serge. I need to be more careful when I copy & paste.