building squid with ecap on Debian

Asked by Rob on 2009-12-22

hi All,
I have a problem and I hope that you can help me.

I am trying to build squid 3.1.0.14-2 with ecap option in (added to rules)

Build fails on following:

###
dpkg-shlibdeps: failure: no dependency information found for /usr/lib/libecap.so.0 (used by debian/squid3/usr/sbin/squid3).
dh_shlibdeps: command returned error code 512
make: *** [binary-predeb-IMPL/squid3] Error 1
dpkg-buildpackage: failure: debian/rules binary gave error exit status 2
###

Guys, how can I solve this problem.

Rob

Question information

Language:
English Edit question
Status:
Solved
For:
eCAP Edit question
Assignee:
No assignee Edit question
Solved by:
Rob
Solved:
2009-12-29
Last query:
2009-12-29
Last reply:
Magus (davdeclerck) said : #1

Hello,

This message indicates that the dependency information file (shlib) for libecap could not be found.

You have two options :
- build an actual Debian package for libecap too and provide an shlib file, that way the dependency will be honoured when building the Squid package
- use the standard build process instead : configure / make / make install ; that does not rely on package dependencies (just be sure you've run ldconfig after building libecap though)

I'm not really an expert, but I hope this will help...

Magus (davdeclerck) said : #2

BTW, I'd suggest you build libecap and Squid 3.1 from the latest source release ; the current beta is more recent than the one in the Debian repositories.

Rob (tenerifemaster) said : #3

sorted, had to apply patch