ecap loads ecap_adater_minimal problem

Asked by sam on 2015-11-01

Dear Friends

      I want to load ecap_adater_minimal . It works fine when I use ./squid -N -d 10 . But when I want to run squid as daemon ,

The squid fails and the error is
          Loading Squid module from '/usr/local/lib/ecap_adapter_minimal.so'
          FATAL: dying from an unhandled exception: file not found

What is problem ? why it works with -N switch and doesn't work as daemon ?

Question information

Language:
English Edit question
Status:
Solved
For:
eCAP Edit question
Assignee:
No assignee Edit question
Solved by:
sam
Solved:
2015-11-02
Last query:
2015-11-02
Last reply:
2015-11-01
Alex Rousskov (rousskov) said : #1

Interesting problem. I do not recall seeing that before. You may be able to figure out why this happens if you strace[1] Squid daemon (with an option to follow child processes). The strace log should contain commands to open the module file with the resulting error codes. What are they?

[1] http://linux.die.net/man/1/strace

If you are not on Linux, your OS should have a similar "system calls tracing" command.

sam (sadegh-sal) said : #2

The problem solved .
The point is Squid just look up /usr/local/libs .I don't know why but squid doesn't attention to LD_LIBRARY_PATH . It sounds silly but I copied my library to /usr/local/lib and problem solved .