How to pass options to an ecap module?

Asked by Gernot Tenchio on 2011-03-09

HI,

I'm using squid-3.1.11 with libecap-0.3. Whenever i try to pass an option to my ecap module squid fails to start.

This is what i've tried...

Version 1:
ecap_service my_service respmod_precache bypass=0 ecap://foo/bar?dings=bums
-> unknown adaptation service option: ecap://foo/bar?dings=bums

Version 2:
ecap_service my_service respmod_precache bypass=0 dings=bums ecap://foo/bar
-> unknown adaptation service option: dings=bums

Version 3:
ecap_service my_service respmod_precache bypass=0 ecap://foo/bar dings=bums
-> garbage after adaptation service URI: dings=bums

What do i wrong? Any help are appreciated.

Thanks And best regards
 Gernot

Question information

Language:
English Edit question
Status:
Solved
For:
eCAP Edit question
Assignee:
No assignee Edit question
Solved by:
Alex Rousskov
Solved:
2011-03-09
Last query:
2011-03-09
Last reply:
2011-03-09
Best Alex Rousskov (rousskov) said : #1

There is no "libecap-0.3" (yet). I assume you are using v0.0.3. That version does not support custom service options.

If you need custom service options, you should use libecap v0.2.0 or later (see release announcement here on Launchpad for important caveats). Please note that Squid v3.1 does not support libecap v0.2.0. For more information about Squid eCAP support, please see http://wiki.squid-cache.org/Features/eCAP

Thanks Alex Rousskov, that solved my question.