Can not see added header "X-ecap", using adapter_modifying

Asked by Dajan Zvekic on 2011-01-29


I am new to ecap and squid. I wanted to start from basics, so I installed squid and adapter examples.
Now I wanted to add new header and I used simple modifying adapter, which adds "X-Ecap" header, but I can not see that header with the firebug. Don't really know what the problem could be. I can see all other headers.

Also, when I include "debug_options ALL,9" in squid.conf file, I can not find in cache.log that this custom header is added, but I can see that other headers are added.

For the installation I followed all instructions.

Thank you,

Dajan Zvekic

Question information

English Edit question
eCAP Edit question
No assignee Edit question
Solved by:
Dajan Zvekic
Last query:
Last reply:
Dajan Zvekic (dajann) said : #1

Ok, when I added these lines into squid.conf it worked.

adaptation_service_set reqFilter eReqmod
adaptation_service_set respFilter eRespmod

adaptation_access respFilter allow all
adaptation_access reqFilter allow all

From the installation guide it was not clear that these lines are needed.

This solved my question.

Alex Rousskov (rousskov) said : #2

Which installation guide are you referring to?

Please keep in mind that adapters are not specific to any host application. You have to rely on host application documentation to figure out how to enable eCAP.

Dajan Zvekic (dajann) said : #3

I was referring to this guide:

Actually there I found needed snippet of config file, but it doesnt say that one need it for adapters to work.

Thanks for response. :)