squid.config for ecap_adapter_sample

Asked by Lucian Bazoi on 2010-12-10

Hi Alex,

  Can you please help me with the Squid configuration part for ecap_adapter_sample for an adapter that doesn't modify anything?

Thank you.
Lucian

Question information

Language:
English Edit question
Status:
Solved
For:
eCAP Edit question
Assignee:
No assignee Edit question
Solved by:
Alex Rousskov
Solved:
2010-12-14
Last query:
2010-12-14
Last reply:
2010-12-13
Alex Rousskov (rousskov) said : #1

For Squid configuration instructions, please see Squid wiki page at http://wiki.squid-cache.org/Features/eCAP

Lucian Bazoi (dezvoltator) said : #2

Hi Alex,
 Thank you for the link.
 I used the config there but the adaptar doesn't work and I can't figure out why.
 Can you give me a clue please?
Thank you.

Lucian Bazoi (dezvoltator) said : #3

2010/12/13 03:18:22.054| fd_close FD 17 /usr/local/squid-20101007/var/run/squid.pid
2010/12/13 03:18:22.054| commSetSelect(FD 17,type=1,handler=0,client_data=0,timeout=0)
2010/12/13 03:18:22.054| commSetSelect(FD 17,type=2,handler=0,client_data=0,timeout=0)
2010/12/13 03:18:22.054| loading Squid module from '/usr/local/lib/ecap_adapter_modifying.so'
2010/12/13 03:18:22.055| loaded Squid module from '/usr/local/lib/ecap_adapter_modifying.so'
2010/12/13 03:18:22.055| Squid modules loaded: 1
2010/12/13 03:18:22.055| Config.cc(96) finalize: Found 2 service configs.
2010/12/13 03:18:22.055| Service.cc(12) Service: creating adaptation service eReqmod
2010/12/13 03:18:22.055| Service.cc(12) Service: creating adaptation service eRespmod
2010/12/13 03:18:22.056| Config.cc(110) finalize: Created 2 message adaptation services.
2010/12/13 03:18:22.056| registered eCAP module service: ecap://e-cap.org/ecap/services/sample/modifying
2010/12/13 03:18:22.056| Adaptation support is off.
2010/12/13 03:18:22.056| ServiceRep.cc(35) finalize: starting eCAP service: ecap://e-cap.org/ecap/services/sample/modifying
2010/12/13 03:18:22.056| ServiceRep.cc(35) finalize: starting eCAP service: ecap://e-cap.org/ecap/services/sample/modifying
2010/12/13 03:18:22.056| Config.cc(122) FinalizeEach: Initialized 2 message adaptation services
2010/12/13 03:18:22.056| ServiceGroups.cc(78) finalize: finalized adaptation set: reqFilter
2010/12/13 03:18:22.056| ServiceGroups.cc(78) finalize: finalized adaptation set: respFilter
2010/12/13 03:18:22.056| Config.cc(122) FinalizeEach: Initialized 2 message adaptation service groups
2010/12/13 03:18:22.056| Config.cc(122) FinalizeEach: Initialized 2 message adaptation access rules
2010/12/13 03:18:22.056| Ready to serve requests.
2010/12/13 03:18:22.057| event.cc(343) schedule: schedule: Adding 'storeMaintain', in 1.00 seconds
2010/12/13 03:18:22.057| event.cc(343) schedule: schedule: Adding 'ipcache_purgelru', in 10.00 seconds
2010/12/13 03:18:22.057| event.cc(343) schedule: schedule: Adding 'fqdncache_purgelru', in 15.00 seconds
2010/12/13 03:18:22.057| event.cc(343) schedule: schedule: Adding 'memPoolCleanIdlePools', in 15.00 seconds

Best Alex Rousskov (rousskov) said : #4

It looks like you are missing "ecap_enable on" in squid.conf. Squid wiki has been updated to suggest that option.

Lucian Bazoi (dezvoltator) said : #5

Thanks Alex Rousskov, that solved my question.