DVD player

Asked by vincewebb

I downloaded EasyUbuntu in order to play DVDs on an Ubuntu 6.06 system.

It downloaded and runs OK but I am left a bit in the dark as to what I am meant to see. I check boxes, it goes away and does stuff. Later on I reload EasyUbuntu to try the same again, the boxes I checked are not checked, I check them again and click OK but it does not enable me to play a DVD?

In the Multimedia tab I check various of the 4 entries always includingthe one for libdvdcss. I click OK and off it goes. The terminal window from which I started shows the following:

vok@t30ubu:~/easyubuntu$ ./launchEU.sh
['/usr/sbin/synaptic', '--hide-main-window', '--non-interactive', '-o=dir::etc=/home/vince/easyubuntu/conf', '-o=dir::etc::sourcelist=sources.list']
In update ['/usr/sbin/synaptic', '--hide-main-window', '--non-interactive', '-o=dir::etc=/home/vince/easyubuntu/conf', '-o=dir::etc::sourcelist=sources.list', '--update-at-startup']
In Install ['/usr/sbin/synaptic', '--hide-main-window', '--non-interactive', '-o=dir::etc=/home/vince/easyubuntu/conf', '-o=dir::etc::sourcelist=sources.list', '--set-selections']

When I try to play a DVD Totem displays the following error:
Totem cannot play this type of media (DVD) because you do not have the appropriate plugins to handle it.

The DVD is region 2 although I doubt that makes any difference.

Any ideas ?

Question information

English Edit question
EasyUbuntu Edit question
No assignee Edit question
Last query:
Last reply:
asuming this is answered ok.
Revision history for this message
Andrew Waldram (andrew-waldram) said :

there doesn't appear to be a gstreamer plugin to support dvd reading so try the following.

install xine and xine-ui
in settings change the raw device to /dev/dvd

As our ilustrious developer havn't given us raw devices.

misssing in udev scripts

if you need a bit more performance google search making raw devices should really be set up in udev rule but this'll probably get you going


modprobe raw
mkdir /dev/raw
mknod /dev/raw/raw1 c 162 1
raw /dev/raw/raw1 /dev/dvd
ln -s /dev/dvd /dev/raw/raw1
may ahve error above as this was off the top of my head

then change xine settings back to rdvd

Revision history for this message
vincewebb (vincewebb) said :

Andrew, thanks for your response.

You say "in settings change the raw device to /dev/dvd"

In what settings ?

Are you advocating I use the Xine front end in place of Totem ?

Revision history for this message
KarlGoetz (kgoetz) said :

Hi vok,
try the latest version of easyubuntu, and see if it works better.
if this ticket is resolved/no longer needed feel free to mark it as such.