Unable to apply changes

Asked by IgnacioMiller

I run the command on your website, EasyUbuntu gets downloaded and unzipped quickly, and then the GUI comes up. I select all of the packages I want installed, including the Nvidia driver and then I press okay. It downloads packages and then gives me this error:

Unable to apply changes: Fix broken packages first.

What do I do? I really want to make the full transistion from Windows to Ubuntu but this is making it difficult. Any help you can give me would be appreciated!


Question information

English Edit question
EasyUbuntu Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
richmark (richmarkgabs) said :

unable to install yahoo messenger

Revision history for this message
Michael Otteneder (m-otteneder) said :

Please tell us more details. Like what branch of Ubuntu and EasyUbuntu are you using? And maybe you could paste your shell output.

Revision history for this message
Michael Otteneder (m-otteneder) said :

Have you enabled Universe and Multiverse?
Please take a look at this:http://www.ubuntulinux.nl/source-o-matic

Revision history for this message
IgnacioMiller (dan-17) said :

I failed to add earlier that my technical knowledge of Linux is very low, the command line is quite foreign to me, I depend on written out commands, etc.

I am using 6.06 Dapper Drake Ubuntu, if that is what you mean by branch. I downloaded the latest version of EasyUbuntu off of the website. How can I obtain the shell output to give to you?

I believe I have enabled Universe and Multiverse, but I don't really know what to do with that link nor the .lst I can generate from it.

Thanks for the responses,

Revision history for this message
Michael Otteneder (m-otteneder) said :

Newbies and non-technical users are always welcome but it would be a good idea to read a beginner unix tutorial:http://www.ee.surrey.ac.uk/Teaching/Unix/

To copy the output just mark it with the mouse,and then past it with the middle mouse-button(or the left and right).

The link i gave you generates your /etc/apt/sources.list that is the file which tells ubuntu where to look for packages.

If universe and multiverse are enabled you should have a line looking like this in your sources.list:
deb http://archive.ubuntu.com/ubuntu dapper universe multiverse

if not add the line,run sudo apt-get update and then retry EasyUbunut

Hope that helps

Revision history for this message
Leona (leona-devon) said :

Got the same problem here, Ubuntu Draper Drake 6.06, used the link to create a source.list file. Has the required 'deb' line in, ran apt-get update, but still get the same error, Error dialog box, Could not apply changes, fix broken packages first.

I am running an AMD 64 with the 64bit edition of Ubuntu, console out put.
System sanity check: PASSED!
amd64 detected
['/usr/sbin/synaptic', '--hide-main-window', '--non-interactive', '-o=dir::etc=./conf', '-o=dir::etc::sourcelist=sources.list']
In update ['/usr/sbin/synaptic', '--hide-main-window', '--non-interactive', '-o=dir::etc=./conf', '-o=dir::etc::sourcelist=sources.list', '--update-at-startup']In Install ['/usr/sbin/synaptic', '--hide-main-window', '--non-interactive', '-o=dir::etc=./conf', '-o=dir::etc::sourcelist=sources.list', '--set-selections']

I've installed this on 3 other machines and never had a problem before, why now?



Revision history for this message
Leona (leona-devon) said :

Solved by a workaround, don't installed the Movie plugin, they don't work in Ubuntu64, (should be removed from list????).

Revision history for this message
IgnacioMiller (dan-17) said :

Yes, that worekd for me, thank you Leona. I too believe the movie codec(s) should be removed from the Ubuntu64 version of EasyUbuntu until such a time as they are functional.

Revision history for this message
Hakan Nilsson (nilssongrey) said :

I have got the same problem as described above (6.06 on an AMD Turion 64) - At first I got an error message about a missing public key. Finding an earlier posting on this solved that, but not remainingeError message Can't apply changes. Fix broken packages first." Synaptic doesn't find any broken packages.

Revision history for this message
spnoe (spnoe) said :

 I get this message when I try to install Flash etc "Unable to apply changes: Fix broken packages first".
How do I fix Files. I have tried the "Fix broken packages" in my UBUNTU 6.6 but nothing seems to happen. Any suggestions most welcome

Easy Unbuntu is a great idea thanks you guys.