Repository ppa:duplicity-team/ppa is no longer available?

Asked by Symak on 2020-05-11

Hi,
I have an issue installing duplicity on Ubuntu 16.04 from ppa:duplicity-team/ppa repository:

# apt-add-repository ppa:duplicity-team/ppa
Cannot add PPA: 'ppa:~duplicity-team/ubuntu/ppa'.
The team named '~duplicity-team' has no PPA named 'ubuntu/ppa'
Please choose from the following available PPAs:
 * 'duplicity-develop-git': duplicity-develop-git
 * 'duplicity-release-git': duplicity-release-git

Suggested ppa:duplicity-team/duplicity-release-git repo contains packages for Ubuntu 18, 19 and 20 only.

And here's what I get when run "apt update" on old server with duplicity previously installed from ppa:duplicity-team/ppa :

Err:14 http://ppa.launchpad.net/duplicity-team/ppa/ubuntu xenial Release
  403 Forbidden [IP: 91.189.95.83 80]
Reading package lists... Done
E: The repository 'http://ppa.launchpad.net/duplicity-team/ppa/ubuntu xenial Release' does not have a Release file.

Question information

Language:
English Edit question
Status:
Answered
For:
Duplicity Edit question
Assignee:
No assignee Edit question
Last query:
2020-05-11
Last reply:
2020-05-11

The 0.7-series PPAs have been removed. Python 2 has reached EOL, thus the 0.7-series of duplicity is at EOL. There will be no 0.7 releases after 0.7.19, which is available at https://launchpad.net/duplicity/0.7-series/0.7.19. Please upgrade to 0.7.19, but first do:

$ sudo apt remove duplicity

to make sure there are no complications.

Symak (symak) said : #2

1) Since 0.7-series PPAs have been removed which one should be used for Ubuntu 16.04 ?

2) Is there an Ubuntu package of 0.7.19 ?

1) There is no PPA for 16.04.

2) No, just remove the PPA from your system. 0.7.x is at EOL.

If you have updated in the last year, duplicity should be at 0.7.19 anyway. It's that old.

Can you help with this problem?

Provide an answer of your own, or ask Symak for more information if necessary.

To post a message you must log in.