Backup to ssh/sftp Backend is failing on my Raspbian (Debian Jessie)

Asked by nils on 2016-11-03

Hi there,
I'm using Duplictiy (installed from source, Version 0.7.10) on my freshly installed Raspbian system. Duplicity in invoked by duply and basically works fine as long as I'm using my Dropbox as a target. As soon as I try to switch to a SSH target (pub key authentication), I get the following error:

Backend error detail: Traceback (most recent call last):
  File "/usr/local/bin/duplicity", line 1546, in <module>
    with_tempdir(main)
  File "/usr/local/bin/duplicity", line 1540, in with_tempdir
    fn()
  File "/usr/local/bin/duplicity", line 1375, in main
    action = commandline.ProcessCommandLine(sys.argv[1:])
  File "/usr/local/lib/python2.7/dist-packages/duplicity/commandline.py", line 1117, in ProcessCommandLine
    backup, local_pathname = set_backend(args[0], args[1])
  File "/usr/local/lib/python2.7/dist-packages/duplicity/commandline.py", line 1006, in set_backend
    globals.backend = backend.get_backend(bend)
  File "/usr/local/lib/python2.7/dist-packages/duplicity/backend.py", line 223, in get_backend
    obj = get_backend_object(url_string)
  File "/usr/local/lib/python2.7/dist-packages/duplicity/backend.py", line 209, in get_backend_object
    return factory(pu)
  File "/usr/local/lib/python2.7/dist-packages/duplicity/backends/ssh_paramiko_backend.py", line 254, in __init__
    raise BackendException("sftp negotiation failed: %s" % e)
BackendException: sftp negotiation failed: Channel closed.

BackendException: sftp negotiation failed: Channel closed.

Some googling brought me to the python-paramiko packet as the scapegoat but I have the latest version of it installed (using apt).
I also turned the verbosity level up and can see that the SSH authentication basically works, the error happens directly after the authentication.

Do you have any advice for me? Is it possible that this is a bug in Duplicity?

Thanks
Nils

Question information

Language:
English Edit question
Status:
Solved
For:
Duplicity Edit question
Assignee:
No assignee Edit question
Solved by:
nils
Solved:
2016-11-07
Last query:
2016-11-07
Last reply:

Have you tried ssh+pexpect://? That would be the next approach.

nils (dernils) said : #2

Hi Kenneth,
Thanks for asking back. No, I actually did not try that. However, the situation changed a bit.
After hours and hours of debugging, I changed to another SSH target and now the backup is working. It seems that thy Synology diskstation that I used as a target before, has some really strange implementation of SSH.
I can't really figure out, where the exact reason lays but I'm glad that it is working now.
Nils

Following up: does the native sftp work with Synology? My guess is that it's something in paramiko that is maybe not quite right.