Duplicity stopped recognizing the S3 backup scheme

Asked by Hannes Ebner on 2011-10-19

I run Duplicity from the PPA on Lucid. Last night I got the following message when the backup script ran:

"UnsupportedBackendScheme: scheme not supported in url: s3+http"

Some hours before that duplicity was upgraded to 0.6.16-0ubuntu0ppa6~lucid1 which I guess means that the latest version of the PPA is broken (0.6.15 worked). Is there any workaround or do I have to downgrade to 0.6.08b-0ubuntu2.1 in Lucid?

Question information

Language:
English Edit question
Status:
Answered
For:
Duplicity Edit question
Assignee:
No assignee Edit question
Last query:
2011-10-19
Last reply:
2011-11-17
derp herp (junkmail-trash) said : #1

You will have to downgrade. This is an issue with the S3 multipart upload requiring some other python dependencies.

This bug has been fixed and will be in the 0.6.17 release. It is in trunk now.

Can you help with this problem?

Provide an answer of your own, or ask Hannes Ebner for more information if necessary.

To post a message you must log in.