AttributeError: 'module' object has no attribute 'gpg_options'

Asked by pkaeding on 2010-03-11

I am using the latest version of duplicity (0.6.08), and I am getting the following error:

Traceback (most recent call last):
  File "/usr/bin/duplicity", line 1239, in ?
    with_tempdir(main)
  File "/usr/bin/duplicity", line 1232, in with_tempdir
    fn()
  File "/usr/bin/duplicity", line 1205, in main
    full_backup(col_stats)
  File "/usr/bin/duplicity", line 416, in full_backup
    globals.backend)
  File "/usr/bin/duplicity", line 294, in write_multivol
    globals.gpg_profile, globals.volsize)
  File "/usr/lib/python2.4/site-packages/duplicity/gpg.py", line 272, in GPGWriteFile
    file = GPGFile(True, path.Path(filename), profile)
  File "/usr/lib/python2.4/site-packages/duplicity/gpg.py", line 105, in __init__
    if globals.gpg_options:
AttributeError: 'module' object has no attribute 'gpg_options'

This occurs when I execute the following command:

/usr/bin/duplicity -v3 --full-if-older-than 14D --encrypt-key=B8C500C9 --sign-key=B8C500C9 --exclude /share/osowski --exclude /share/michalson --include=/share/kaeding --include=/home/jkaeding --include=/home/malvarado --exclude=** / s3+http://mybucket/marshall

I am not sure if I am missing some python module relating to GPG? I have python-gnupginterface installed (using the Ubuntu package).

Does this look familiar to anyone? Thanks!

Question information

Language:
English Edit question
Status:
Solved
For:
Duplicity Edit question
Assignee:
Michael Terry Edit question
Solved by:
Eelco Dolstra
Solved:
2010-03-12
Last query:
2010-03-12
Last reply:
2010-03-11
Whiteboard:
Mike, would you check this out? Maybe we need yet another fix. Thanks!

Today's release should fix this bug, 0.6.08a.

pkaeding (patrick-kaeding) said : #2

I'm afraid I am still getting the same error, after upgrading to 0.6.08.a. Could this be a different bug?

Or is there some meaningless option I can pass to --gpg-options to make optparse happy?

Michael Terry (mterry) said : #3

Nooooo! You're sure you have 0.6.08a and it's installed correctly?

There is a workaround: pass --gpg-options " " (a blank space).

But it really hopefully shouldn't be needed with 08a. I'll look further into it's behavior I guess.

Best Eelco Dolstra (e-dolstra) said : #4

I ran into this problem with 0.6.08 and 0.6.08a as well. Looking at the diff between the two tarballs, it seems that the change in http://bazaar.launchpad.net/~duplicity-team/duplicity/0.7-series/revision/637 never made it into 0.6.08a...

pkaeding (patrick-kaeding) said : #5

Thanks, I upgraded to 0.6.08b, and it seems to be working now. The backup is still running, but it failed early when it was broken, so I am confident that this issue is resolved.

(And I didn't send the blank space as --gpg-options, so it it is definitely fixed.)

Thanks!

pkaeding (patrick-kaeding) said : #6

Thanks Eelco Dolstra, that solved my question.