Do I need to build libdrizzle first when building drizzle

Asked by tingwei on 2009-04-09

Hi,
  I get the latest drizzle trunk(drizzle-2009.04.973.tar.gz) and try to build it by myself, but when I run ./configure it will report that the libdrizzle is not found in the path. But I do saw the libdrizzleclient is in the src directory.
I am not sure whether I need build libdrizzle first. but I remember this is ok when I build version drizzle-2009.03.962-trunk.tar.gz

Thanks.

Question information

Language:
English Edit question
Status:
Solved
For:
Drizzle Edit question
Assignee:
No assignee Edit question
Solved by:
tingwei
Solved:
2009-04-10
Last query:
2009-04-10
Last reply:
2009-04-09
Lee Bieber (kalebral) said : #1

libdrizzle is now a required library that needs to be built and installed on your system. See http://drizzle.org/wiki/Compiling#libdrizzle for details

Eric Day (eday) said : #2

Hi!

You need to install the new libdrizzle, libdrizzleclient is in the process of being removed. You can find a tarball of the new libdrizzle at https://launchpad.net/libdrizzle or build from lp:libdrizzle

-Eric

tingwei (david-fengtw) said : #3

Thank you very much! Let me have a try.