no .gcda files found

Asked by Verbus on 2010-10-16

Greetings,

I am getting the following:

Generating drizzle_lcov.info
lcov --directory . --capture --base-directory . --output-file drizzle_lcov.info
Capturing coverage data from .
Found gcov version: 4.4.4
Scanning . for .gcda files ...
geninfo: ERROR: no .gcda files found in .!
make: *** [drizzle_lcov.info] Error 255

demoadmin@demo:~/Downloads/drizzle7-2010.10.01$

Verbus at gmail dot com

Question information

Language:
English Edit question
Status:
Solved
For:
Drizzle Edit question
Assignee:
No assignee Edit question
Solved by:
Verbus
Solved:
2010-10-16
Last query:
2010-10-16
Last reply:
2010-10-16
Andrew Hutchings (linuxjedi) said : #1

Hi Verbus,

Are you using ccache? If so please disable it first.

Verbus (verbus) said : #2

Hi,

ccache is not installed on my system - so says Synaptic Package Manager. I am running Ubuntu 10.10.

Verbus

Patrick Crews (patrick-crews) said : #3

Did you configure the server as:
./configure --enable-coverage [other flags and whatnot]
?

That must be done to build the server with the gcov counters. make lcov
just runs lcov, which is a utility to gather up the information from the
gcov files and create the html reports.

On Sat, Oct 16, 2010 at 1:21 PM, Verbus <
<email address hidden>> wrote:

> Question #129758 on Drizzle changed:
> https://answers.launchpad.net/drizzle/+question/129758
>
> Status: Answered => Open
>
> Verbus is still having a problem:
> Hi,
>
> ccache is not installed on my system - so says Synaptic Package Manager.
> I am running Ubuntu 10.10.
>
> Verbus
>
> --
> You received this question notification because you are a member of
> Drizzle-developers, which is an answer contact for Drizzle.
>

Verbus (verbus) said : #4

Hi,

Following your recommendation I got:

$make && make lcov
.
.
.
Processing file version/versionudf.cc
Writing directory view page.
Overall coverage rate:
  lines......: 78.6% (45232 of 57517 lines)
  functions..: 78.1% (4877 of 6243 functions)
  branches...: 63.8% (26748 of 41922 branches)

Problem solved. Thanks!

Verbus