python-libdrizzle installation problem in Ubuntu 10.04 lucid

Asked by Andrey Sukhanov on 2011-02-21

Hello,

I am trying to install python-libdrizzle in my Ubuntu 10.04 lucid box.

I installed libdrizzle-dev from repositories. Then I downloaded python-libdrizzle-0.08.2. There are some errors while installing:
---
~/python-libdrizzle-0.08.2$ sudo python setup.py install
running install
running bdist_egg
running egg_info
writing python_libdrizzle.egg-info/PKG-INFO
writing top-level names to python_libdrizzle.egg-info/top_level.txt
writing dependency_links to python_libdrizzle.egg-info/dependency_links.txt
reading manifest file 'python_libdrizzle.egg-info/SOURCES.txt'
reading manifest template 'MANIFEST.in'
writing manifest file 'python_libdrizzle.egg-info/SOURCES.txt'
installing library code to build/bdist.linux-i686/egg
running install_lib
running build_py
running build_ext
building 'drizzle._libdrizzle' extension
gcc -pthread -fno-strict-aliasing -g -O2 -DNDEBUG -g -fwrapv -O3 -Wall -Wstrict-prototypes -fPIC -I/usr/local/include/python2.6 -c libdrizzle.c -o build/temp.linux-i686-2.6/libdrizzle.o
libdrizzle.c: In function ‘init_libdrizzle’:
libdrizzle.c:9445: error: ‘DRIZZLE_CAPABILITIES_SSL_VERIFY_SERVER_CERT’ undeclared (first use in this function)
libdrizzle.c:9445: error: (Each undeclared identifier is reported only once
libdrizzle.c:9445: error: for each function it appears in.)
libdrizzle.c:9446: error: ‘DRIZZLE_CAPABILITIES_REMEMBER_OPTIONS’ undeclared (first use in this function)
error: command 'gcc' failed with exit status 1
---

Could anybody advise something?

Thanks,
Andrey

Question information

Language:
English Edit question
Status:
Solved
For:
Drizzle Interfaces Edit question
Assignee:
No assignee Edit question
Solved by:
Andrey Sukhanov
Solved:
2011-02-22
Last query:
2011-02-22
Last reply:
Andrew Hutchings (linuxjedi) said : #1

Problem due to a very slight API change roughly when libdrizzle was merged into drizzle. Pre-compiled versions should still work without issue.

Opened bug #723034

Yes, it works, thanks a lot.