stokes-iterative demo error- hypre or ml

Asked by Amanda Diegel on 2013-07-25

Hi All,

I'm a beginner at FEniCS. I recently installed FEniCS 1.2.0 for the MAC OS X10.8. I'm trying to get the stokes-iterative demo to run but I keep encountering the error "Sorry, this demo is only available when DOLFIN is compiled with AMG preconditioner, Hypre or ML." I've been trying to read up on how to compile DOLFIN with Hypre using PETSc but am unsure how to do this in the FEniCS framework. Has anyone been able to get this demo to run and would you be willing to share the trick?

Just to be clear, I can get the other demos to run, such as the Poisson demo. It is just the stoke-iterative demo I'm having trouble running.

Thanks!

Amanda

Question information

Language:
English Edit question
Status:
Solved
For:
DOLFIN Edit question
Assignee:
No assignee Edit question
Solved by:
Johannes Ring
Solved:
2013-08-05
Last query:
2013-08-05
Last reply:
2013-07-31
Best Johannes Ring (johannr) said : #1

FEniCS no longer uses Launchpad for Questions & Answers. Please consult the documentation on the FEniCS web page for where and how to (re)post your question: http://fenicsproject.org/support/

Amanda Diegel (diegel-u) said : #2

Thanks Johannes Ring, that solved my question.