Installation issues

Asked by Daniel James Tarplett on 2013-01-25

Hi

I'm trying to install Feincs on a new precise. I'm getting

daniel@ubuntu:~/MEK4300$ sudo apt-get install fenics
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 fenics : Depends: libdolfin1.0-dev (>= 1.0.0) but it is not going to be installed
          Depends: python-dolfin (>= 1.0.0) but it is not going to be installed
          Depends: dolfin-doc (>= 1.0.0) but it is not going to be installed
          Depends: dolfin-bin (>= 1.0.0) but it is not going to be installed
          Depends: python-ffc (>= 1.0.0) but it is not going to be installed
          Depends: python-instant (>= 1.0.0) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Any help would be very much appreciated.

Best regards

Daniel

Question information

Language:
English Edit question
Status:
Solved
For:
DOLFIN Edit question
Assignee:
No assignee Edit question
Solved by:
Daniel James Tarplett
Solved:
2013-01-25
Last query:
2013-01-25
Last reply:
2013-01-25

You should at the FEniCS PPA to your software sources. Then you'll download the latest stable release (v1.1). Check out the instructions here.

http://fenicsproject.org/download/ubuntu_details.html#ubuntu-details

Thank you for the reply Paul. Fenics is now working perfectly.

Best regards

Daniel