FOI DL Listings producing double results!

Asked by Richard H. on 2008-02-18

For some strange reason, the DL Listing objects being used in the test Zope instance of arana are listing documents twice when they are from the FOI.

For example - go to the test zope and then /uob_staff_test/foi - we have one DL Listing object to show publication scheme category 6 docs, and one other for showing category 8 docs. When displayed on the web page, the DL Listing objects are showing each doucment twice.

Question information

Language:
English Edit question
Status:
Solved
For:
Document Library Edit question
Assignee:
No assignee Edit question
Solved by:
Sylvain Viollon
Solved:
2008-04-29
Last query:
2008-04-29
Last reply:
2008-04-29

This question was originally filed as bug #192858.

Richard H. (richard-hewison) said : #1

Okay, this is actually worse than I thought - it's now doing it in all DL Listing object's output - have a look at uob_staff_test/isd and you'll see two cherry-picked docs (which are fine) and then the final docs are pulled in fro ma DL listing object and it's produced the same DL link twice!

Kit Blake (kitblake) said : #2

We'll investigate this as part of the DL Enhancements 2.

Richard H. (richard-hewison) said : #3

I suspect that this issue might be related to the service for the DL being moved from within the Silva instance to the root of the overall Zope instance. I can't be certain of course, but this all used to work fine and it all went worng shortly after I started testing the inheritance side of things between Silva and Zope.

Sylvain Viollon (thefunny) said : #4

Actually, it's only because the service have been moved.

Sylvain Viollon (thefunny) said : #5

The Document Library service contains a catalog, which is used to search and display entries. Catalog entries are identified by the path of indexed items, which are stored inside the service itself. When you moved the service, the path of theses items changed, so they were re-added to the catalog a second time, triggering this behavior.

I have purged the catalog, and re-update the service, this fix this issue.

It's more a question since there is no code to change to fix it.

Richard H. (richard-hewison) said : #6

Just to be clear, can you elaborate just a little on how you resolved this?

(i) Purging the catalog - where do you do this? In Zope I assume, but where is the option?
(ii) Re-update the service - I assume this is via the 'update' button within the service (in Zope)?

Thanks,

Sylvain Viollon (thefunny) said : #7

Yes.

And it was only because the object 'service_doclib' was moved inside Zope.

Richard H. (richard-hewison) said : #8

Sorry, but where in Zope was the option that you used to 'purge' the catalog?

Best Sylvain Viollon (thefunny) said : #9

On the 'service_doclib', you can click on the link 'go to "dl" storage'. After, you can select the 'service_oai_catalog' in the select list, and click on the button 'edit'. You can now click on the 'Advanced' tab, and here you will a 'Clear catalog' button.

Richard H. (richard-hewison) said : #10

Thanks Sylvain Viollon, that solved my question.