No package 'gtk+-2.0' found installing from source

Asked by James Lorenzen on 2010-02-05

I am trying to build docky from source but running into a missing package.
I checked out the source, ran the long apt-get install command provided in the wiki. Looks like it is unable to get libgtk2.0-dev 2.18.3-1ubuntu2.1.

Err http://us.archive.ubuntu.com karmic-updates/main libgtk2.0-dev 2.18.3-1ubuntu2.1
  404 Not Found [IP: 91.189.88.31 80]
E: Failed to fetch http://us.archive.ubuntu.com/ubuntu/pool/main/g/gtk+2.0/libgtk2.0-dev_2.18.3-1ubuntu2.1_i386.deb: 404 Not Found [IP: 91.189.88.31 80]

Obviously when I run autogen, it complains about not having gtk+-2.0:

checking for GTK... configure: error: Package requirements (gtk+-2.0 >= 2.14.3) were not met:

No package 'gtk+-2.0' found

Ironically, Synaptic Manager shows that I have libgtk2.0-0 version 2.18.3-1ubuntu2.1 installed.

Question information

Language:
English Edit question
Status:
Answered
For:
Docky Edit question
Assignee:
No assignee Edit question
Last query:
2010-02-05
Last reply:
2010-02-10
Robert Dyer (psybers) said : #1

I find this package:

http://us.archive.ubuntu.com/ubuntu/pool/main/g/gtk+2.0/libgtk2.0-dev_2.18.3-1ubuntu2.2_i386.deb

which seems newer than the one your apt is trying to get. Maybe do a

$ sudo apt-get update && sudo apt-get upgrade

and see if it updates your libgtk2.0-0 to the right version that it can pull in the -dev?

James Lorenzen (jameslorenzen) said : #2

Well it did upgrade but autogen still doesn't work.

I went ahead and ran:

$ sudo apt-get update && sudo apt-get upgrade

and it did upgrade libgk2.0-0 to 2.18.3-1ubuntu2.2

but when I run ./autogen in the docky directory, it fails saying "No package 'gtk+-2.0' found"

Chris S. (cszikszoy) said : #3

Have you followed the instructions here: http://wiki.go-docky.com/index.php?title=Install ?

You need libgtk2.0-dev.

Can you help with this problem?

Provide an answer of your own, or ask James Lorenzen for more information if necessary.

To post a message you must log in.