Get the 2.1 stable verseion on Ubuntu 10.04 LTS Lucid

Asked by Kenneth Metcalfe on 2011-09-02

How can I get a stable version of the 2.1 series (I need the 2.1 supported docklets) for the current Long Term Support version of Ubuntu?

Thanks!

Question information

Language:
English Edit question
Status:
Solved
For:
Docky Edit question
Assignee:
No assignee Edit question
Solved by:
Kenneth Metcalfe
Solved:
2011-09-20
Last query:
2011-09-20
Last reply:
2011-09-20
Robert Dyer (psybers) said : #1

I believe you will have to compile it from source code. See:

http://wiki.go-docky.com/index.php?title=Installation#Installing_From_Source

While I have followed cookbooks before for compiling and installing from source I am still new to Linux and the command line and don't fully understand all that is going on. I would prefer that Docky 2.1.? be available in a repository for Ubuntu 10.04 especially as 10.04 is a LTS.

However I attempted to follow the instructions given on the wiki with no success. All seemed to go well until I was required to run the $./autogen.sh command when I got a "file not found" error. I did some digging arround and discovered what I presume is a fork of Docky for Maverick which had a autogen.sh file in the source directory but I was unable find one in any of the directories in I checked I also discovered that the version of Docky that was downloaded using the instructions was 2.1.0 while the lastest stable version is 2.1.3. Perhaps the instructions need some updating?

Anyway, I feel in desperate need of more help.

Thanks in anticipation.

Kenneth.

Hello,

Please advise where I can get the 'autogen.sh' file refered to in the compile from source instructions? I am stuck without it.

Thanks,

Kenneth.

Robert Dyer (psybers) said : #4

If you downloaded the source from bzr, then it is already in the main directory. If you downloaded a source tar from launchpad, it may not be included and instead you should run './configure'.

OK!

I flew blind and managed to compile and install version 2.1.4 and it appears to be running fine under Ubuntu 10.04 LTS but the instructions for installing from source need some SERIOUS updating.

After poking around rather blindly I finally managed to get a source downloaded with 'autogen.sh' in it. I then had to (guess and) copy some of the aptitude comands [sudo aptitude install automake libgconf2-dev] for the dependancies from 9.10 before I could get 'autogen.sh to run all the way through. (I am gessing more needs to be added to line 4 [sudo apt-get install bzr libgio2.0-cil-dev ?? ] for the 10.04 instructions.)

In the course of all my pokeing I learnt enough about bazzar to be dangerious and then managed to download what I thought was version 2.1.3 using [bzr branch lp:docky/2.1] however when it was all finished it turned out to be version 2.1.4 I probably should have used [] as I had to substitute the directory '2.1' for 'docky' in all the subsequent commands.

I really wish I had a better understanding of it all.

Kenneth.

ahh.

That explains something the second batch of files I downloaded (prior to post #2) were from launchpad. But the first was using bzr. That downloaded version 2.1.0 in which I could not find a 'autogen.sh' file. Today when I tried again, with a liberal sprinkling of 'sudo's I was successful and found 'autogen.sh' in the home/docky directory. I then hit a "missing dependancies" problem and in the course of solving that I "discovered" other directories from which bzr could download and hence I managed to get version 2.1.3/4.

Thanks all the same. :o)

Kenneth.

Robert Dyer (psybers) said : #7

To be honest, I have been planning (and completely lacking the time) to create a VM for each version of Ubuntu and then nailing down the *exact* commands to compile the source. What we have on the wiki is a best guess, but we usually have several of the deps already installed so we don't know sometimes the full list. ;-)