docky ignores gconf settings

Asked by Magnetizer on 2011-05-13

Hello there,

I am currently using docky version "Docky 2.0.14bzr docky r1455 pre-release" with Linux Mint based on Ubuntu 10.10 in the Gnome version.

I like docky very much but I have one little problem. It unhides too fast when accidentally reaching the edge of the screen, e.g. while trying to use a scrollbar with the mouse. I found there is a setting for this within the gconf-editor, the UnhideDelay.

I killed the docky process from within the terminal and then I typed:

gconftool-2 --type Integer --set /apps/docky-2/Docky/Interface/AutohideManager/UnhideDelay 200
gconftool-2 --type Integer --set /apps/docky-2/Docky/Interface/AutohideManager/UpdateDelay 200
gconftool-2 --type Boolean --set /apps/docky-2/Docky/Items/DockyItem/ShowDockyItem False

I added the last one when I saw it on the web and found that this one also would be nice.

When I look in the gconf-editor I see the new keys, they were added quite nicely.

Then I restarted docky with ALT+F2: docky

The problem is, the new keys do not have any effect on docky's behaviour.

Do you have any suggestions what to do?

Thank you very much and go on developing this great product!

Kind regards,

André Kaldenhoven

Question information

Language:
English Edit question
Status:
Solved
For:
Docky Edit question
Assignee:
No assignee Edit question
Solved by:
Robert Dyer
Solved:
2011-05-20
Last query:
2011-05-20
Last reply:
2011-05-14
Best Robert Dyer (psybers) said : #1

That functionality is only in the 2.1.x branch (or newer) of Docky. You will have to upgrade. We do provide a PPA, which I recommend using.

Magnetizer (magnetizer) said : #2

Thanks Robert,

that makes sense. I thought this functionality was also in the 2.0.x branch.

I'll try the 2.1.x branch later this day.

I assume it is already declared stable?

Thanks again, I really like docky.

Kind regards,

André Kaldenhoven

Robert Dyer (psybers) said : #3

All released versions are considered stable.

Magnetizer (magnetizer) said : #4

Robert, thanks again.

I can confirm that everything works like a charm when using the newer version of docky. I am now on the 2.2.x branch and my settings for UnhideDelay, UpdateDelay and ShowDockyItem are respected.

Kind regards,

André Kaldenhoven

Magnetizer (magnetizer) said : #5

Thanks Robert Dyer, that solved my question.