Docky Item no longer hiding

Asked by Jason Farmer on 2011-01-05

I recently copied over my .gconf settings from another machine with the same version (2.0.10) of docky installed on it. I had the ShowDockyItem set to false to hide the icon and it was working fine.

When I copied the .gconf settings over from the other machine, it no longer seems to affect this Docky icon? I've tried removing the ShowDockyItem value, re-adding it; setting it to false, then true, true then false. Restarting the application just doesn't seem to pick up the setting.

Any thoughts on how to get this to hide?

Question information

Language:
English Edit question
Status:
Solved
For:
Docky Edit question
Assignee:
No assignee Edit question
Solved by:
Robert Dyer
Solved:
2011-01-10
Last query:
2011-01-10
Last reply:
2011-01-09
Robert Dyer (psybers) said : #1

The way to hide is to set:

/apps/docky-2/Docky/Items/DockyItem/ShowDockyItem

to false. If that is not working, my guess is your gconf config is somehow not working properly.

Jason Farmer (jason-terigo) said : #2

Thanks for the response Robery; I originally had that value set and it was working fine on what I thought was version 2.10 of Docky.

I then copied by .gconf settings over to a new system, installed docky 2.10 and it did not read the setting as it always showed the dock icon. So I tried the steps listed in my first post.

I have also recently tried since my first post uninstalling docky 2.10 and reverting back to 2.07 that was in the ubuntu repositories. So I did a complete remove, then rm -rf ~/.gconf/apps/docky-2

When I install a new version now of either 2.10 or 2.06; it doesn't even have the /apps/docky-2/Docky/Items/DockyItem gconf value.

I searched around and didn't see an obvious way to just "create" this gconf key; and I think this is what happened in the first place when I switched machines, installed a newer version of docky and just copied over my .gconf folder (which had this value in it).

Thanks again!

Jason Farmer (jason-terigo) said : #3

Sorry for the typos, and "Robert" not "Robery".... its early still :)

Jason Farmer (jason-terigo) said : #4

Just another thought I had of something I noticed, every time I re-install docky and remove my .gconf directory for it; it resets all the items pinned to the docky.... HOWEVER, I always seem to have the same docklets enabled (which are not the defaults). Are there settings elsewhere I am not aware of?

Robert Dyer (psybers) said : #5

Docky also has configuration (for the addins) in ~/.local/share/docky but this data really should not put any docklets onto your docks.

Best Robert Dyer (psybers) said : #6

You can only hide the Docky item in 2.1.0. You are installing the 2.0.x branch and thus the option is not available.

Jason Farmer (jason-terigo) said : #7

Thanks Robert Dyer, that solved my question.

Jason Farmer (jason-terigo) said : #8

Heh I feel like an idiot now, thanks a lot Robert. Apparently I hadn't realized I added the "stable" ppa rather than development ppa when installing.

Thanks again! In 2.1.0 hide docky works as expected!

Great product btw, keep up the good work!