Can't install helpers for Docky

Asked by Kimmy on 2010-12-27

I can install Docky from Docky Development PPA or Docky Core normally. But I can't install dockmanager with helpers for Docky. The log is (Portuguese):

"Erros foram encontrados durante o processamento de:
 /var/cache/apt/archives/dockmanager_0.1.0~bzr83-0ubuntu1~10.10~dockers1_i386.deb"

I've already tried to install Dockmanager Daemon and I get the same problem.

Using Ubuntu 10.10.

Question information

Language:
English Edit question
Status:
Solved
For:
Docky Edit question
Assignee:
No assignee Edit question
Solved by:
Robert Dyer
Solved:
2010-12-28
Last query:
2010-12-28
Last reply:
2010-12-28
Emre AYTAÇ (eaytac) said : #1

May be the downloaded package is broken. Please try the following commands and try to install again:

sudo apt-get clean
sudo apt-get autoclean

Hope this helps...

Kimmy (kimzedeck) said : #2

Thanks for your answer but the problem persists...

The log in Gnome Terminal:

Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Os NOVOS pacotes a seguir serão instalados:
  dockmanager
0 pacotes atualizados, 1 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.
2 pacotes não totalmente instalados ou removidos.
É preciso baixar 94,8kB de arquivos.
Depois desta operação, 430kB adicionais de espaço em disco serão usados.
Obter:1 http://ppa.launchpad.net/docky-core/ppa/ubuntu/ maverick/main dockmanager i386 0.1.0~bzr83-0ubuntu1~10.10~dockers1 [94,8kB]
Baixados 94,8kB em 2s (40,0kB/s)
(Lendo banco de dados ... 169391 arquivos e diretórios atualmente instalados).
Desempacotando dockmanager (de .../dockmanager_0.1.0~bzr83-0ubuntu1~10.10~dockers1_i386.deb) ...
dpkg: erro processando /var/cache/apt/archives/dockmanager_0.1.0~bzr83-0ubuntu1~10.10~dockers1_i386.deb (--unpack):
 tentando sobrescrever '/usr/share/dockmanager/data/skype_dnd.svg', que também está no pacote faenza-icon-theme 0.8
dpkg-deb: sub-processo colar foi morto por sinal (Canal quebrado)
Erros foram encontrados durante o processamento de:
 /var/cache/apt/archives/dockmanager_0.1.0~bzr83-0ubuntu1~10.10~dockers1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Robert Dyer (psybers) said : #3

Would you mind translating that to English? You can probably just set your locale to English and then re-run the command.

Best Robert Dyer (psybers) said : #4

Ok nevermind, Google translated it for me just fine. :)

  trying to overwrite `/ usr / share / dockmanager / data / skype_dnd.svg ', which is also in package Faenza-icon-theme 0.8

That is your problem. For some stupid reason your theme installs images to that directory. This Faenza theme is bad. Either uninstall it (because it is doing bad things and imo shouldn't exist anymore) or manually delete the file(s) conflicting and let DockManager install them.

Kimmy (kimzedeck) said : #5

Thanks Robert Dyer, that solved my question.