What is Docky "compositing" and how do I do that?

Asked by KnowBuddy on 2010-11-23

What is Docky "compositing" and how do I do that? I have no idea what Compiz or Metacity is, and auto search for /apps/ string in my file system finds no hits. I'm running Ubuntu Maverick 10.10, Gnome 2.32.0, and Docky 2.0.7. When I login to Ubuntu, Docky autoloads, but I usually see a popup notice box saying "Docky needs compositing." None of the listed Q&A here seemed to answer my question. TIA.

Question information

Language:
English Edit question
Status:
Answered
For:
Docky Edit question
Assignee:
No assignee Edit question
Last query:
2010-11-24
Last reply:
2011-02-15
Vincenzo salvo (venik88) said : #1

to enable compiz through the ubuntu GUI, System > Preferences > Appearance. Click on the "Visual Effects" tab and select either "Normal" or "Extra".

KnowBuddy (multimuse3) said : #2

Not a solution. That was already the setting from first install, and has not been changed. That suggestion makes no difference. The problem and notice to composite consistently occurs repeatedly while those ARE the settings configured. No one has answered the questions: 1. What is "compositing" Docky? 2. What makes Docy "need compositing" (or not)? 3. What is compiz (or metacity)? 4. Is there more than 1 way to composite something, perhaps other than a docker utility like Docky? 5. How do I make the startup popup notice to composite it stop occurring, since setting or resetting Visual Effects to normal or extra makes no difference on this issue? Thanks.

Robert Dyer (psybers) said : #3

Compositing is something window managers do (compiz, metacity has optional compositing support, etc). Please google it if you need more info.

PaweĊ‚ Bara (keirangtp) said : #4

Sometimes when Ubuntu starts, I get this notification too even though Compiz is always turned on. My guess is, this happens when Docky autostarts before Compiz. It causes' no problems though - the notification disappears after a second and two and everything works like expected.

Florian Dorn (florian-dorn) said : #5

I experience the same as Pawel Bara. Docky complains about a missing compositing support.

Dennis Bolshakov (b-dennis-v) said : #6

to enable compiz through the ubuntu GUI, System > Preferences > Appearance. Click on the "Visual Effects" tab and select either "Normal" or "Extra". By Vincenzo salvo.

Good answer! I thought my visual effects was set on "extra" but after I have red the answer I've looked and everything was unchecked some how. Then I checked "extra" again, restart the Docky and problem was solved.
Thanks to Vincenzo salvo!

Can you help with this problem?

Provide an answer of your own, or ask KnowBuddy for more information if necessary.

To post a message you must log in.