Gmail docklet authenticates, but doesn't actually check mail

Asked by Phil McPhee on 2010-10-28

I've installed Docky 2.0.7 in Ubuntu 10.10, and I really like it (I used to use Cairo, but this is better). I've had some problems with the Gmail notifier though. My account successfully authenticates, but the docklet doesn't ever check my mail. If I right-click on it and choose "check mail", nothing happens. The other menu items ("view inbox") work fine - Chrome starts up and goes to Gmail. I should add that it worked after it was first installed, but didn't work the next day.

I'm not sure if it's related, but the other problem I have is that choosing "start when computer starts" in the config menu doesn't make any difference - I still have to manually start Docky each time I log on.

Any ideas much appreciated!

Question information

Language:
English Edit question
Status:
Answered
For:
Docky Edit question
Assignee:
No assignee Edit question
Last query:
2010-11-07
Last reply:
2011-06-26
Enio San (enio-san) said : #1

Have you found the solution for the Gmail docklet?
I have the same issue here. But Docky does load when the computer starts, I actually noticed when Docky stopped working, I was surfing the web and lost wi-fi signal at home, and as soon it was restored, GmailChecker never worked again, and exactly the same thing happened with the weather docklet.

It would be really useful to have it back online.

shakedkoffee (shakedkoffee) said : #2

Same problem here. Had the same problem with 10.04 before updating to 10.10 amd64. Hope to solveit soon because Docky's mail applet is fundamental.

Phil McPhee (mcphee-phil) said : #3

I've done a bit more looking into this...

First up, I tried uninstalling Docky completely using Synaptic, and then removed the config files in ~/.gconf/apps/docky-2 and ~/.local/share/docky. I then reinstalled it from the PPA. The fresh install of Docky as expected had retained none of my preferences. I'm still having the exact same issues with the GMail applet though.

When I run Docky from the terminal using "Docky -d", I can see that when I right click on the applet and choose "Check mail", Docky tries to fetch the atom feed for my account:

[Info 16:21:39.696] [GMailAtom] Fetching Atom feed: https://mail.google.com/mail/feed/atom/

... but the applet doesn't update. However, if I try to re-authenticate my account with an incorrect password I get:

[Info 16:30:30.020] [GMailAtom] Fetching Atom feed: https://mail.google.com/mail/feed/atom/
[Error 16:30:30.904] [GMailAtom] Invalid username: The remote server returned an error: (401) Unauthorized.
[Debug 16:30:30.905] [GMailAtom] Response status: Unauthorized - Unauthorized

... which shows that at least something's getting through, so maybe it's not a network problem at all. Could it be a problem with parsing the Atom file?

Phil McPhee (mcphee-phil) said : #4

By the way... uninstalling and reinstalling from the PPA fixed the autostart so at least I'm not manually starting each time I login!

Enio San (enio-san) said : #5

Hey Phil,
I think this could be something with Google... they probably changed something, so the APP should be updated to make it compatible, I guess.
Hope this is fixed soon.

Enio San (enio-san) said : #6

I just installed an update, which included a DOCKY update and the GMAIL CHECKER is working now... as well as the weather checker.
I was about to get rid of it when noticed that it started to work. Hope it stays this way.

shakedkoffee (shakedkoffee) said : #7

Ok, I can confirm that. The latest update from the development Docky PPA fixes the bug. That's a relief.

fadi aboona (fady904) said : #8

Hi all,
the docky-gmail never checks for emails! i have Docky 2.2.0 bzr docky r1815 ppa. GMAIL have successfully validated my gmail user name and password but never checks or notifies about new emails! what gives?

thank you.

fadi aboona (fady904) said : #9

Hi again,
I had to enter keyring password for it to work. I don't like keyring and never used it till now with gmail notifier. it's working now.

thanks

Leszek (bigl-aff) said : #10

I've axactly the same problem with latest Docky from PPA - Docky 2.2.1 bzr docky r1841 ppa. My keyring is for sure unlocked and GMAIL have successfully validated my gmail user name and password but never checks or notifies about new emails.

Can you help with this problem?

Provide an answer of your own, or ask Phil McPhee for more information if necessary.

To post a message you must log in.