There is no option to have the dock underneath opened windows and a docking issue.

Asked by R4VEN on 2010-08-25

Okay in the Dock Configuration menu under Dock Configuration there is the option to hide the dock with options "None" "Autohide" "Intellihide" and "Windows Dodge" there is no option to have it set to underneath windows, so for example if I am surfing the web through a browser and have that window maximized if I accidentally go over the area where the dock is it will pop up and interfere even in "Windows Dodge" mode it is pretty much set-up as "Hide" as it will pop up when you go over the area.

What I am saying is it would be nice to have an option there (if there is an option for this I have yet to come across it) to have it set so that it can function on the desktop as a dock but when you have windows open over the top of the dock it will not "pop" out over the top of the window as it kind of gets in the way sometimes.

Also another thing I might mention, when you have the dock set at the bottom of the screen and have the "Hiding" mode set to "None" the bar does not cover all the icons like it does if it is set to the sides or top of the screen, when I say that I mean the dock comes only halfway up the icons, leaving the other half of the icons protruding from the bar, this is quite ugly as you can see the background wallpaper when you have a window maximized.

I have included a picture to help clarify the above "issue"

I find your dock the best one around as its simple, elegant and very practical, although the main issue above with there being no option to have the dock set underneath the windows makes me stick to having just a regular ubuntu toolbar, if there are changes made to accommodate that option please let me know!


Question information

English Edit question
Docky Edit question
No assignee Edit question
Last query:
Last reply:
Chris S. (cszikszoy) said : #1

For your first question: That's the point of the dock, so that you can have easy access to running applications, launchers and more, simply by bringing your mouse near the edge of the screen. This behavior is nothing new, this is exactly how the gnome panel (when set to autohide) functions. There is a gconf key (assuming you're running the PPA or development version) that will allow you to specify a timeout that the dock waits when you hover over the screen area. Look on this page , for a key called "UnhideDelay" (/apps/docky-2/Docky/Interface/AutohideManager/UnhideDelay).

For question #2: turn off 3d background.

LisandroVCR (lisandro-v22) said : #2

I think the only thing that comes out from this is that when in panel mode + 3D it should just expand to the sides. I really don't know how many users prefer the half way mode and how many the "expanded 3D" but whatever the answer I think if 3D is checked it should still be 3D even if nobody uses it. I don't know if it was clear.

You know 3D + Panel

    _______________________ |
  / \ |
/ \ |

LisandroVCR (lisandro-v22) said : #3

I tried to draw the dock, anyway if you don't understand it let me know and I do a little drawing

Can you help with this problem?

Provide an answer of your own, or ask R4VEN for more information if necessary.

To post a message you must log in.