No package 'gio-sharp-2.0' found

Asked by AJerman on 2010-06-02

I'm having an issue building new builds of Docky. To be honest, the last revision I build was 1309, so I can't tell exactly when it happened, but judging from the commit notes in revision 1406 or 1407, I'd guess that's where my issue starts. I won't claim to be an expert when it comes to compiling on Linux, or Linux all together, but I'm usually fairly capable.

My issue is as the title states, whenever I try to do something with the Docky source, be it a make uninstall or ./autogen.sh, I end up erroring with the message: "No package 'gio-sharp-2.0' found".

Now, from what I read, gio-sharp should be a part of gtk-sharp, which I have installed, however, I can't get rid of this error. I've tried updating all packages, tried doing a sudo apt-get build-dep docky (which seems to be dependencies on the PPA version, so it may not be current anyway), tried seaching for anything about gio-sharp that I could with little help.

At this point it's beyond me. Maybe I'm missing something simple, but I can't figure it out.

Question information

Language:
English Edit question
Status:
Solved
For:
Docky Edit question
Assignee:
No assignee Edit question
Solved by:
Chris S.
Solved:
2010-06-02
Last query:
2010-06-02
Last reply:
2010-06-02
Best Chris S. (cszikszoy) said : #1

You need to add our PPA to get the gio-sharp package.

https://edge.launchpad.net/~docky-core/+archive/ppa

AJerman (ajerman) said : #2

Ahh, got it, thanks. I wasn't using the PPA because I was using bzr to pull the source. I thought gio-sharp was supposed to work with a package I already had, didn't realize I needed to use the PPA to grab it. All is good now.

AJerman (ajerman) said : #3

Thanks Chris S., that solved my question.