Simple RSS Reader does not keep opml file

Asked by sucider

When i try to set the opml file in the "Simple RSS Reader v1.0" with this file "" ,for example, and click on the "close" button, then "settings" button again, the "file" field is as it was before i tried to pick the file. The result is that i am unable to use the feeds i want with the plugin.
I have tried with opml files generated with "" too. Same...

Also when Gnome-Do is started in terminal, i got this message :
"[Error 21:34:55.938] Could not read OPML file Document Type Declaration (DTD) is prohibited in this XML. Line 1, position 10."

I don't know if it's linked since i tried with different files.

My questions are : is it a known bug ? Is there something special to write in the opml file to make it work ? Am i doing something wrong ?

I don't know if it's the right place for this topic but i like the idea of rss reading via gnome-do so i'd really like to make it work properly :)

PS : no info on ""

Gnome-do is awesome !

Question information

English Edit question
Do Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
sucider (sucider) said :

I found a way to avoid the problem by editing the key whith gconf-editor :

I entered the adress of my local opml file instead of "". Now it works.

In conclusion there are two intricated problems :

- First there is no opml file at the exact adress given by default. So the plugin cannot display feeds from opml.
- Then the plugin seems unable (at least on my machine and after several atempts of uninstalling/reinstalling) to change the opmlfile key.

The important problem is the plugin's.
So the question now is : is it a bug or does it come from my installation only ?

Revision history for this message
RachaelB (8-launchpad-rlb-me) said :

No its not just you :)

I had exactly the same problem and editing the location of the .opml file in gconf is the only solution that I could come up with as well.

Hope this helps!

Now to sort out the plugin.... :-/

Can you help with this problem?

Provide an answer of your own, or ask sucider for more information if necessary.

To post a message you must log in.