Do

How to avoid using arrow keys

Asked by nakolah on 2009-08-14

Hello,

I'd like to avoid using the arrow keys for moving up and down in the result's list.

For example, using vim-like shortcuts :

CTRL + j to go down (instead of down arrow)
CTRL + k to go up (instead of up arrow)

would avoid moving the hand to the arrow keys. I think it's the spirit of gnome-do, however, I could'nt find a way to do this.

Thanks a lot if you can find a way !
-- nakolah

Question information

Language:
English Edit question
Status:
Solved
For:
Do Edit question
Assignee:
No assignee Edit question
Solved by:
Alex Launi
Solved:
2009-08-14
Last query:
2009-08-14
Last reply:
2009-08-14
Best Alex Launi (alexlauni) said : #1

With 0.8.2 you can go to the preferences interface and rebind the keys to
whatever you like. The keybindings stuff in 0.8.2 can be a little bit weird
at times, 0.8.3/0.9 (we're not sure which will be the next release) will
have more robust keybinding preferences.

--
--Alex Launi

nakolah (y-huerre) said : #2

Thank you ! I didn't try this version and was using ubuntu default repository.
Sadly, look likes there is just a few plugins installed for this version, but I guess I will be able to install them anyway).

Thanks again, have a nice day !
-- nakolah

nakolah (y-huerre) said : #3

Thanks Alex Launi, that solved my question.

Alex Launi (alexlauni) said : #4

All the plugins are the same

--
--Alex Launi

nakolah (y-huerre) said : #5

Yes sorry, I just noticed that the upgrade had removed "gnome-do-plugins" package, don't know why.
Problem solved, thank you !

Bitterjug (bitterjug) said : #6

I had not read this and tried to set up and down as K and J etc,(no control) now, of course, I can't type these keys into do. Would happily reset them in the keyboard prefs but the arrow keys are not recognised when entering a new shortcut. In fact when I double click on the shortcut to enter a new one and then press one of my arrow keys i get a bell signal (intercepted by compiz and turned into a window wobble).

I had a look in .gnome2 for a settings file to delete to reset my configuration, but couldn't find one. Any suggestions?

Thanks

Mark