Do

Showing icon of custom launcher

Asked by Peregrinati on 2009-07-02

I added a custom launcher for Songbird to the Ubuntu 9.04 "Sound & Video" menu. I set the icon to a .png file I found in the Songbird directory, and it works fine in the menu. Gnome-do, however, doesn't display the icon; instead I get the default "springboard" icon. Is there any way to get it to show the icon?

I tried restarting gnome-do, and then I tried shutting gnome-do down and doing a "complete removal" from Synaptic and installing it again. I'm not certain that the complete removal worked though because when it started up again it still remembered my glass theme.

Question information

Language:
English Edit question
Status:
Solved
For:
Do Edit question
Assignee:
No assignee Edit question
Solved by:
Peregrinati
Solved:
2009-07-06
Last query:
2009-07-06
Last reply:
Peregrinati (ben-barbour) said : #1

Ok, now I can't remove the Songbird launcher. I removed it from the ubuntu main menu (just trying to see if creating it again with the icon would fix my issue - I just added Eclipse the same way I had Songbird, only it's icon worked). Anyways, the Songbird launcher won't leave Gnome-Do. I've restarted it, and checked /usr/share/applications; it's not there.

Peregrinati (ben-barbour) said : #2

Solved the second bit with the help of Question #35584. It was hiding in ~/.local/share/applications. Deleted it there and it went away. Strange that my search for "Songbird" didn't turn it up... I selected the options to include "hidden and backup" files.

When I re-created the launcher item with the proper icon, gnome-do showed the icon correctly, so I guess this is solved.