Gnome Do (Files and folders plugin) does not run shell scripts

Asked by akahanek on 2009-07-02

There is a sript, it is marked as executable. I find it in Gnome Do, select "Run" (Run an application, script or other executable) and press <Enter>. NOTHING happens.

The same file runs properly when pressing <Enter> in Nautilus or when running from terminal or "Run application" window (Alt+F2).

I have tried also Gnome Do "Run in terminal" - this works fine. Am I doing something wrong?

Thank you for any hint.


Question information

English Edit question
Do Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:

This question was reopened

Buttink (buttink) said : #1

Hmmmmm not to be nosey but what does the script do? I have scripts as well (start ps3 media server) and myn work fine. Are these scripts intended to be ran inside of the terminal? Have you tried just doing something simple in a script, like start up firefox ... something trivial to make sure it isnt a special case when running scripts? Something tells me this script is for information you need to read. Gnome do is probably running it but you never see it. It would be my thought.

akahanek (akahanek) said : #2

That was my first thought too. My original script contains one line to run rdesktop with some parameters. Then I tried to run simple script which has only one line:


This script runs fine (starts gedit) when pressing <Enter> from Nautilus.

Alex Launi (alexlauni) said : #3

What does the icon look like when you search and find your script? Is it a file item or a text item? A screenshot of what Do looks like before you hit enter might be useful

akahanek (akahanek) said : #4

Here is the screenshot of the file:


Alex Launi (alexlauni) said : #5

Looks fine. So what happens when you run it? Does anything get printed if
you run Do from a terminal with --debug and then run the script with Do?

-- Alex Launi

akahanek (akahanek) said : #6

Debug output:

[Info 10:27:45.197] [EnvironmentService] Executing "/home/ales/rdp/"

and nothing happens.

I have tried again to type "/home/ales/rdp/" to terminal and after <Enter> the gedit is launched properly. So the script is ok.

Launchpad Janitor (janitor) said : #7

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

akahanek (akahanek) said : #8

According to debug output it seems that everything is ok, but really nothing happens. Do you have any clue what could be the problem?

Thanks, Ales

Launchpad Janitor (janitor) said : #9

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

akahanek (akahanek) said : #10

Still no response? Is there anybody, who run such script with no problems?
Thanks, Ales

Alex Launi (alexlauni) said : #11

Can you put the full contents of the script into this question?

akahanek (akahanek) said : #12

After trying many scripts I ended up with a very very simple script which starts gedit - it has only one line:


akahanek (akahanek) said : #13

I have found the solution. I added the


at the beginning of my script and now it works fine! Thank you for your help anyway.


Alex Launi (alexlauni) said : #14

This is why I asked you to paste the full script, I could have seen that
issue. Glad it's working now.

And for the future, you should always put the shebang at the beginning of
your shell scripts.

-- Alex Launi