Do

Why can't I enable the Tomboy plugin?

Asked by mwheeler on 2008-06-11

Using the preferences window in Gnome-Do 0.5 from the Hardy PPA I can't seem to enable the Tomboy plugin (along with a few others). Many other Gnome-Do plugins enable just fine, but the checkbox will just not check for some of them. Am I missing something obvious, or do I need to file a bug?

Question information

Language:
English Edit question
Status:
Solved
For:
Do Edit question
Assignee:
No assignee Edit question
Solved by:
mwheeler
Solved:
2008-06-12
Last query:
2008-06-12
Last reply:
2008-06-12
Asa Ayers (asa-ayers) said : #1

I had that problem with the Window Manager plugin. Try starting gnome-do in a terminal and then watching what happens when you check the box. My problem was that I was missing a library, so the plugin downloaded but it couldn't load.

mwheeler (mpwheeler) said : #2

Thanks for the help!

attempting to enable the Tomboy plugin generated this message

Installing "Do.Tomboy,1.0" addin...
The following add-ins will be installed:
 - Tomboy v1.0
Installing Tomboy v1.0

ERROR: /home/mwheeler/.local/share/gnome-do/plugins/addins/Do.Tomboy.1.0/Tomboy.addin.xml already exists

After navigating to the directory and removing the xml file as well as the Tomboy.dll file I was able to enable the plugin. Problem solved!

Michael Rooney (mrooney) said : #3

I have the same problem with the Window Manager plugin. However this clearly seems like a bug, why does it care if a file already exists? I sure don't :)