Do

Shortcut not launching gnome-do

Asked by Johnnie Walker on 2008-05-05

I can't seem to get Gnome-do to launch when i press the keyboard shortcut. I think that something else is intercepting the shortcut (though nothing seems to run).

I am running ubuntu 8.04 using gnome (I just recently switched back from openbox). I am running compiz and I have tomboy installed as well. I did have a problem whereby i accidentally unset the key_binding key, but it wasn't working before that, and i re added the key.

My output from gnome-do (launched using the command, then quit).

05/05/2008 22:33:28 [Info]: Deserializing HistogramRelevanceProvider...
05/05/2008 22:33:28 [Error]: Deserializing HistogramRelevanceProvider failed: Could not find file "/home/uzusan/.config/gnome-do/relevance3".
05/05/2008 22:33:28 [Info]: Successfully loaded "Applications" item source.
05/05/2008 22:33:28 [Info]: Successfully loaded "Define" action.
05/05/2008 22:33:28 [Info]: Successfully loaded "Copy to..." action.
05/05/2008 22:33:28 [Info]: Successfully loaded "Move to..." action.
05/05/2008 22:33:28 [Info]: Successfully loaded "Directory Scanner" item source.
05/05/2008 22:33:28 [Info]: Successfully loaded "Firefox Bookmarks" item source.
05/05/2008 22:33:28 [Info]: Successfully loaded "GNOME Special Locations" item source.
05/05/2008 22:33:28 [Info]: Successfully loaded "Email" action.
05/05/2008 22:33:28 [Info]: Successfully loaded "Manually-typed path items" item source.
05/05/2008 22:33:28 [Info]: Successfully loaded "Open" action.
05/05/2008 22:33:28 [Info]: Successfully loaded "Open Terminal Here" action.
05/05/2008 22:33:28 [Info]: Successfully loaded "Open URL" action.
05/05/2008 22:33:29 [Info]: Successfully loaded "Recent Files" item source.
05/05/2008 22:33:29 [Info]: Successfully loaded "Reveal" action.
05/05/2008 22:33:29 [Info]: Successfully loaded "Run" action.
05/05/2008 22:33:29 [Info]: Successfully loaded "Run in Terminal" action.
05/05/2008 22:33:29 [Error]: Failed to load item source from /usr/lib/gnome-do/Do.exe: Method not found: 'Default constructor not found...ctor() of Do.Core.DoItemSource'.
05/05/2008 22:33:29 [Info]: Successfully loaded "Internal GNOME Do Items" item source.
05/05/2008 22:33:29 [Info]: Successfully loaded "GNOME Do Item Sources" item source.
05/05/2008 22:33:29 [Info]: Searching for plugins in directory /home/uzusan/.local/share/gnome-do/plugins
05/05/2008 22:33:29 [Info]: Searching for plugins in directory /usr/local/share/gnome-do/plugins
05/05/2008 22:33:29 [Warn]: Could not read plugins directory /usr/local/share/gnome-do/plugins: Directory '/usr/local/share/gnome-do/plugins' not found.
05/05/2008 22:33:29 [Info]: Searching for plugins in directory /usr/share/gnome-do/plugins
05/05/2008 22:33:29 [Info]: Successfully loaded "Append to..." action.
05/05/2008 22:33:29 [Info]: Successfully loaded "Epiphany Bookmarks" item source.
05/05/2008 22:33:29 [Info]: Successfully loaded "Evolution Contacts" item source.
05/05/2008 22:33:29 [Info]: Successfully loaded "Play Slideshow" action.
05/05/2008 22:33:29 [Info]: Successfully loaded "Create empty file" action.
05/05/2008 22:33:29 [Info]: Successfully loaded "GNOME Session Commands" item source.
05/05/2008 22:33:29 [Info]: Successfully loaded "GCalculate" action.
05/05/2008 22:33:29 [Info]: Successfully loaded "Map" action.
05/05/2008 22:33:29 [Info]: Successfully loaded "Launchpad" action.
05/05/2008 22:33:29 [Info]: Successfully loaded "Locate Files" action.
05/05/2008 22:33:30 [Info]: Successfully loaded "Search Web" action.
05/05/2008 22:33:30 [Info]: Successfully loaded "Send to Pastebin" action.
05/05/2008 22:33:30 [Info]: Successfully loaded "Chat" action.
05/05/2008 22:33:30 [Info]: Successfully loaded "Pidgin Buddies" item source.
05/05/2008 22:33:30 [Info]: Successfully loaded "Play" action.
05/05/2008 22:33:30 [Info]: Successfully loaded "Add to Play Queue" action.
05/05/2008 22:33:30 [Info]: Successfully loaded "Rhythmbox Music" item source.
05/05/2008 22:33:30 [Info]: Successfully loaded "Connect with SSH" action.
05/05/2008 22:33:30 [Info]: Successfully loaded "SSH Hosts" item source.
05/05/2008 22:33:30 [Info]: Successfully loaded "Stock Quote" action.
05/05/2008 22:33:30 [Info]: Successfully loaded "Thunderbird Contacts" item source.
05/05/2008 22:33:30 [Info]: Searching for plugins in directory /usr/share/gdm/gnome-do/plugins
05/05/2008 22:33:30 [Warn]: Could not read plugins directory /usr/share/gdm/gnome-do/plugins: Directory '/usr/share/gdm/gnome-do/plugins' not found.
05/05/2008 22:33:30 [Info]: Universe contains 428 objects.
36
05/05/2008 22:33:31 [Info]: Binding key '<Super>space' for '/apps/gnome-do/preferences/key_binding'. You may change this keybinding with Configuration Editor (gconf-editor).

Question information

Language:
English Edit question
Status:
Solved
For:
Do Edit question
Assignee:
No assignee Edit question
Solved by:
phil
Solved:
2008-05-08
Last query:
2008-05-08
Last reply:
2008-05-08
phil (philsmithson) said : #1

I don't profess to be an expert on anything Linux related, much less on Gnome-Do but I think I had a similar problem.

There are two places you should look for your key bindings, open gconf-editor from the terminal and navigates to apps-->metacity then look in the "Keybinding_commands" section and in there is a list of all programs that are available for binding to keys. For example, on my command_4 the value I have is 'gnome-do' (w/o the quotes). Next, go to global_keybindings and in there match up the run_command_x where x is the command you want to run and type the keybinding you want in the 'value' section. I use '<Alt>z' (w/o the quotes) as I have <Super> bound to minimise desktop but you can type in <Super>space in the box and it should work.

In Advanced Desktop Effects Settings, you can also see your keybindings but I think that they are read from the gconf-editor's file so they should be the same, worth a look though. (General options-->Command tab)

Johnnie Walker (uzusan) said : #2

That didn't seem to work. I tried adding gnome-do and <Super>space into the command 4 (and made sure it was still in the gnome-do prefs as well) but it still wont launch.

Also, i've switched off compiz just now (seemed to be interfering with my wine install).

Best phil (philsmithson) said : #3

Let's check if <Super>space is taken by another key binding...try changing it to <Alt>z then we'll know if it's a problem with Gnome Do or just that something else has stolen that particular keybinding

phil (philsmithson) said : #4

Your answer might already have been answered here: https://answers.launchpad.net/do/+question/28984

Johnnie Walker (uzusan) said : #5

I checked that question before i posted and i've already readded the key.

I'll try changing the key binding just now.

Johnnie Walker (uzusan) said : #6

Thanks phil, that solved my question.

Johnnie Walker (uzusan) said : #7

Looks like <super>space is being caught by something else. ill just keep it as alt-z.

On a side note, changing command_4 etc to <Super>space caused a strange effect. Once i launched gnome-do, every time i pressed space it launched again :)

I just changed it back to normal and it got rid of it.

Jymbob (james-scholes) said : #8

That sounds like your <super> key is not set up correctly. Have a look on ubuntuforums for how to check this. I can't remember offhand.

Also, if you follow the advice phil gives above (setting up a launcher in apps->metacity) then rather than calling up the existing gnome-do, you're actually starting a new instance every time, which is not to be recommended.

Nakarian (cvfsoft+launchpad) said : #9

Once you set the key, try restarting Gnome Do. So bring it up (probably with <Super>space), click on the arrow in the upper right hand corner, then click on Quit. Then press <Alt>F2, type in "gnome-do" (without quotations) and press enter, then try your new shortcut after a few seconds.

This worked for me.