Do

GMail Contact Plugin problem: "@" shown as "%40"

Asked by George Lin on 2010-12-27

I followed this guide to set up my Kubuntu 10.04 to use Gmail as default email client.
   http://do.davebsd.com/wiki/GMail_Contacts_Plugin
Somehow the perl script replaces the "@" in the email addresses in the To: field with "%40". I could use the original HOWTOGEEK guide but that method cannot compose an email in a regular, full Gmail window.

Thanks!

Question information

Language:
English Edit question
Status:
Solved
For:
Do Edit question
Assignee:
No assignee Edit question
Solved by:
George Lin
Solved:
2010-12-28
Last query:
2010-12-28
Last reply:
George Lin (imgeorgelin) said : #1

To answer my own question, and I realize it's not so much about Gmail but rather the perl script listed on the wiki. Anyway, composing in a new, full Gmail tab can be achieved by simply putting the following code in the command box in "Default Applications" setting page (cut and pasted from the HOWTOGEEK guide at http://www.howtogeek.com/howto/ubuntu/set-gmail-as-default-mail-client-in-ubuntu/):
   firefox -remote “openurl(https://mail.google.com/mail/?view=cm&fs=1&to=`echo $1 | sed ’s/mailto://’`,new-tab)”
Be careful about the quotes and the character "&" since different system treat them differently and one might have to experiment a little be.