Do

How do I install Gnome Do 0.8.4 from tar.gz?

Asked by Nacho on 2010-12-09

Hi,

I'm using ubuntu 10.10 maverick. Uninstalled Gnome Do in the process and now for some reason it won't let me install it from repositories.

I downloaded the tar.gz archive of version 0.8.4 but, what am I supposed to run in terminal to have it installed. I tried running install-sh but it says I'm missing an input file.

Thanks in advance for your help.

Question information

Language:
English Edit question
Status:
Answered
For:
Do Edit question
Assignee:
No assignee Edit question
Last query:
2010-12-10
Last reply:
2010-12-10
Amano (amano) said : #1

I ran sudo apt-get build-dep gnome-do first
and then in the directory of the tar file I ran ./configure then make and then make install...it runs but it has no plugins

Nacho (nmarquest) said : #2

Thanks for your answer. Could you explain why each step? I try not to run in terminal commands I don't know.

Thanks!

Nacho (nmarquest) said : #3

If I run ./configure I get an error because I am missing intltool version 0.35.0 but I do have it installed.
I changed mod of install-sh but still not installing. And I also tried make install-sh. What am I missing?

Amano (amano) said : #4

You may need to install sudo apt-get install build-essential that installs all programs needed to compile source code

The sudo apt-get build-dep gnome-do installs any dependencies that gnome-do needs to complies from source.

Im no programmer but I believe the configure command is like a pre-scan to get everything readu
make is what complies the program into binaries
and sudo make install(i forgot sudo in the first answer) actually installs everything in the proper directories.

Nacho (nmarquest) said : #5

Alright thanks!

Ran all commands but they say:

$./configure
configure: error: Your intltool is too old. You need intltool 0.35.0 or later."

or when I run

$ sudo make install-sh
make: Nothing to be done for `install-sh'.

or when I run

$ sudo make install
make: *** No rule to make target `install'. Stop.

Thanks for your help.

Amano (amano) said : #6

Not sure then. I am sure someone will make a deb packages soon. Also none of the plugins work and I couldnt complie them so i went back to Kupfer and Synapse until that is fixed

Can you help with this problem?

Provide an answer of your own, or ask Nacho for more information if necessary.

To post a message you must log in.