Plugin loader 'python' was not found, when enable plugin

Asked by Volos_86 on 2017-08-27

Hi.
I try to create new plugin for diodon. FIrst, I try to run your plugin-sample.
I cloned repo to my ubuntu 16.04, created folder in ~/.local/share/diodon/plugins and copy files there.
Next I try to enable plugin in diodon plugins tab (In the list on this tab, plugin is exist).
I received an error:
An error occured: Plugin loader 'python' was not found
But I have python on my Ubuntu

$ python
python python2 python2.7 python3 python3.5 python3.5m python3m

What I'm doing wrong?
Thanks

PS: I'm new one in developing app for PC, so I have some question in the future, please don't hate me
PS2: if I'll have a new question, will I create new question or write here?

Question information

Language:
English Edit question
Status:
Answered
For:
Diodon Edit question
Assignee:
No assignee Edit question
Last query:
2017-08-27
Last reply:
2017-09-02
Oliver Sauder (sao) said : #1

Welcome. Always great to see people working on Diodon plugins. If you have any further question feel free to raise them here on Launchpad. Occasionally I am also found on Freenode #diodon as sao if you want to have a one on one discussion.

Concerning your question you need to make sure that you have diodon-dev and libpeas-1.0-0-python2loader installed:

sudo apt install diodon-dev libpeas-1.0-0-python2loader

Even though Python plugins are support most plugins are currently written in Vala so this interface is better tested. You can find some 3rd party plugins for example here https://github.com/RedHatter/diodon-plugins

Can you help with this problem?

Provide an answer of your own, or ask Volos_86 for more information if necessary.

To post a message you must log in.