Diodon not working on Ubuntu 15.04

Asked by Luís de Sousa

Dear all,

I just installed Diodon (1.2) on Ubuntu 15.04. It is not capturing any of the strings copied to the clipboard and thus only shows the "<Empty>" in the list.

Is this a bug or is there some additional configuration required in this version?

Thank you.

Question information

English Edit question
Diodon Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Oliver Sauder (sao) said :

Quickly tested myself and it seems that Diodon is suffering the issue Bug 1435033 on Ubuntu 15.04 as well. This only happens the very first time Diodon starts though after installation so if you close Diodon and open it again it should start working.

Revision history for this message
Luís de Sousa (luis-de-sousa) said :

Hi Oliver, thank you for the reply.

I have restarted Diodon (through the GUI) but it is still not capturing the strings copied to the clipboard. Should I try a restart some other way?

Thank you.

Revision history for this message
Oliver Sauder (sao) said :

It might be a configuration issue then see here https://esite.ch/2014/08/why-does-diodon-not-save-anything-to-the-clipboard-history/

Is that the case?

Revision history for this message
Luís de Sousa (luis-de-sousa) said :

Hi again Oliver,

I have Zeitgeist on, I only disabled it for chat logs.

Btw, I now have CopyQ functioning without issue, so the clipboard seems to be accessible.


Revision history for this message
Oliver Sauder (sao) said :

I have checked again on a fresh 15.04 installation and when Diodon is started the second time it works as always.

There has to be something else on your machine then.

To figure this out can you close Diodon and also CopyQ (two clipboard managers at the same time might cause issues) and run the following:
G_MESSAGES_DEBUG=all diodon > diodon_debug.log

Then copy something to the clipboard and check whether history is empty. If it is please paste the content of diodon_debug.log here so I can better analyze.

Revision history for this message
Jesse Johnson (holocronweaver) said :

I have done this debugging step. I attempted to copy the URL of this bug report. It appears to copy, but never shows up in Diodon. I have closed and opened Diodon multiple times, but still no clipboard entries ever appear in the dropdown menu.

Here is the output:

(diodon:3686): Gtk-DEBUG: Connecting to session manager
** (diodon:3686): DEBUG: main.vala:80: Activate DiodonApplication
** (diodon:3686): DEBUG: sql-schema.vala:204: schema_version is 10
** (diodon:3686): DEBUG: keybinding-manager.vala:140: Unbinding key <Ctrl><Alt>V
** (diodon:3686): DEBUG: keybinding-manager.vala:98: Binding key <Ctrl><Alt>V
** (diodon:3686): DEBUG: keybinding-manager.vala:129: Successfully binded key <Ctrl><Alt>V
** (diodon:3686): DEBUG: zeitgeist-clipboard-storage.vala:239: Get recent 25 items
** (diodon:3686): DEBUG: zeitgeist-clipboard-storage.vala:532: Created 0 clipboard items
** (diodon:3686): DEBUG: utility.vala:103: Active window 0x4400398
** (diodon:3686): DEBUG: utility.vala:129: Copied by process with pid 3289
** (diodon:3686): DEBUG: utility.vala:83: Path is /usr/lib/firefox/firefox (deleted)
** (diodon:3686): DEBUG: controller.vala:329: received item of type DiodonTextClipboardItem from clipboard 1 with label https://answers.launchpad.net/diodon/+question/266...
** (diodon:3686): DEBUG: zeitgeist-clipboard-storage.vala:271: Add item https://answers.launchpad.net/diodon/+question/266... to clipboard
** (diodon:3686): DEBUG: zeitgeist-clipboard-storage.vala:306: event actor set to application://firefox.desktop
diodon_debug.log (END)

Revision history for this message
Jesse Johnson (holocronweaver) said :

I should have added I also am on Ubuntu 15.04, latest updates.

Revision history for this message
Oliver Sauder (sao) said :

Seems Diodon works as expected but the Zeitgeist backend doesn't record anything.

Can you double check whether following settings is set to true:
gsettings get org.gnome.desktop.privacy remember-recent-files

and if not needs to change to true.

Also if this is set to true resetting the Zeitgeist database might help - you can do this by first closing Diodon and then run the following commands:
mv ~/.local/share/zeitgeist/ ~/.local/share/zeitgeist-old
zeitgeist-daemon --replace

Let me know if one of those steps is successful.

Revision history for this message
Jesse Johnson (holocronweaver) said :

Indeed, that setting was false. After following both steps and then restarting Diodon twice, I am able to see clipboard history! I am not sure if the second step is necessary since I followed both before testing.

Revision history for this message
Oliver Sauder (sao) said :

OK great. I assume the first step would have been enough if it was false in the first place.

Revision history for this message
Jesse Johnson (holocronweaver) said :

Is this then a bug with the default Gnome settings in Ubuntu 15.04, or is this a problem with how Zeitgeist interfaces with Gnome? I don't want Gnome remembering my recent files if possible - I just want to copy clipboard contents.

Revision history for this message
Oliver Sauder (sao) said :

The name of the option is a bit confusing as it mainly talks about enabling recording of activities within Gnome and also Unity. This can then be filtered what you want to record in the Privacy dialog.

Unfortunately recording of recently used documents and clipboard are currently the same option (checkbox Documents) - you can find more details about this in Bug #1312704 where we want to change this. The rest of the recording can be disabled though.

If you are really concerned about privacy can you also run Zeitgeist completely in memory.

You can do this by setting following env var (e.g. adding it to ~/.pam_environment):

You will need to logout and login again that the env var will be set properly.

Revision history for this message
Jesse Johnson (holocronweaver) said :

Ok, so the GUI solution in Ubuntu 15.04 is (for the sake of others having this problem):

* Open Security & Privacy app -> Files & Applications tab.
* Enable 'Record file and application usage'.
* Check the box next to 'Documents' - all other boxes can be left unchecked if you desire privacy.

Hopefully Oliver's Zeitgeist patch will be accepted and the next version of Ubuntu will separate clipboard privacy from documents.

Until this is fixed, maybe a warning could pop up if Diodin detects that the Gnome privacy setting is set to false?

Can you help with this problem?

Provide an answer of your own, or ask Luís de Sousa for more information if necessary.

To post a message you must log in.